Issues opening Sonarr

modem7
Posts: 212
Joined: Tue Mar 20, 2012 6:00 pm

Issues opening Sonarr

Postby modem7 » Sat Mar 09, 2019 2:04 pm

Hey guys,

I changed Sonarr settings to try and get reverse proxy working (changed enable SSL + URL base as per https://github.com/Sonarr/Sonarr/wiki/Reverse-Proxy) and now it seems that Sonarr refuses to start.

Getting the following:
Redirecting to /bin/systemctl status sonarr.service
● sonarr.service - Sonarr Daemon
Loaded: loaded (/usr/lib/systemd/system/sonarr.service; enabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Sat 2019-03-09 20:58:40 GMT; 37s ago
Process: 16575 ExecStart=/usr/bin/mono /var/hda/web-apps/sonarr/html/NzbDrone.exe -nobrowser -data /var/hda/web-apps/sonarr (code=exited, status=1/FAILURE)
Main PID: 16575 (code=exited, status=1/FAILURE)

Mar 09 20:58:38 localhost.localdomain systemd[1]: Started Sonarr Daemon.
Mar 09 20:58:39 localhost.localdomain mono[16575]: Press enter to exit...
Mar 09 20:58:40 localhost.localdomain systemd[1]: sonarr.service: Main process exited, code=exited, status=1/FAILURE
Mar 09 20:58:40 localhost.localdomain systemd[1]: sonarr.service: Unit entered failed state.
Mar 09 20:58:40 localhost.localdomain systemd[1]: sonarr.service: Failed with result 'exit-code'.
Do we know where the location of the config.xml for sonarr lives (version installed via the amahi app store) to see if I can revert some files?

If I run "/usr/bin/mono /var/hda/web-apps/sonarr/html/NzbDrone.exe -nobrowser -data /var/hda/web-apps/sonarr" sonarr starts, but it doesn't seem to load it's database.

Further note: Nginx is loaded on a raspberry pi, so no direct changes apart from the above have been done to the Amahi installation.

Worst case, where is it that Amahi's Sonarr install keeps it's backups? I know my Radarr install keeps it in /home/radarr/.config/Radarr/Backups/scheduled/

modem7
Posts: 212
Joined: Tue Mar 20, 2012 6:00 pm

Re: Issues opening Sonarr

Postby modem7 » Sat Mar 09, 2019 5:34 pm

OK, here's what I've done so far:

I've managed to finally find the backup locations (thankfully one made 5 days ago).
Uninstalled
Reinstalled

Sonarr doesn't start via service, comes up with following error:
Redirecting to /bin/systemctl status sonarr.service
● sonarr.service - Sonarr Daemon
Loaded: loaded (/usr/lib/systemd/system/sonarr.service; enabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Sun 2019-03-10 00:32:28 GMT; 1s ago
Process: 20844 ExecStart=/usr/bin/mono /var/hda/web-apps/sonarr/html/NzbDrone.exe -nobrowser -data /var/hda/web-apps/sonarr (code=exited, status=1/FAILURE)
Main PID: 20844 (code=exited, status=1/FAILURE)

Mar 10 00:32:26 localhost.localdomain systemd[1]: Started Sonarr Daemon.
Mar 10 00:32:27 localhost.localdomain mono[20844]: Press enter to exit...
Mar 10 00:32:28 localhost.localdomain systemd[1]: sonarr.service: Main process exited, code=exited, status=1/FAILURE
Mar 10 00:32:28 localhost.localdomain systemd[1]: sonarr.service: Unit entered failed state.
Mar 10 00:32:28 localhost.localdomain systemd[1]: sonarr.service: Failed with result 'exit-code'.
It does however, now start (with the correct settings + database) if I do: /usr/bin/mono /var/hda/web-apps/sonarr/html/NzbDrone.exe -nobrowser -data /var/hda/web-apps/sonarr

User avatar
bigfoot65
Project Manager
Posts: 11399
Joined: Mon May 25, 2009 4:31 pm

Re: Issues opening Sonarr

Postby bigfoot65 » Sun Mar 10, 2019 6:47 pm

Recommend you submit a bug report.
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: Bing [Bot] and 2 guests