CLOSED: Webmin installation problem on Amahi 11

gwynap
Posts: 11
Joined: Wed Feb 06, 2019 11:23 am

CLOSED: Webmin installation problem on Amahi 11

Postby gwynap » Wed Feb 06, 2019 11:59 am

I recently installed Amahi 11 fresh. Webmin does not install properly, with the log extremely similar to bug 2338. Anyone else seeing this? Thanks!

User avatar
bigfoot65
Project Manager
Posts: 11441
Joined: Mon May 25, 2009 4:31 pm

Re: Webmin installation problem on Amahi 11

Postby bigfoot65 » Wed Feb 06, 2019 3:15 pm

We need more details.

Please provide the URL using the command line terminal for:

Code: Select all

apaste —sysinfo
Also what does the /var/logs/amahi-app-installer.log show foe the app?
ßîgƒσστ65
Applications Manager

gwynap
Posts: 11
Joined: Wed Feb 06, 2019 11:23 am

Re: Webmin installation problem on Amahi 11

Postby gwynap » Wed Feb 06, 2019 4:02 pm

https://paste.fedoraproject.org/paste/a ... H5SU12Xi8w

log:

======= app install begin @ 2019-02-06 15:19:59 -0600 ==========
Installing app id uicm8zt4hf under /var/hda/platform/html/script/.. ENV=production
file /var/hda/tmp/amahi-download-cache/189587329ebd2783456b06e6d9604ba8938cf393 picked up from cache.
Your HDA services have been restarted.
Your HDA services have been restarted.
Enabling webmin service
Failed to enable unit: Unit file webmin.service does not exist.
Configuring Amahi settings
/var/hda/web-apps/webmin/elevated/start.sh: line 4: /etc/webmin/config: No such file or directory
sed: can't read /etc/webmin/miniserv.conf: No such file or directory
sed: can't read /etc/webmin/miniserv.conf: No such file or directory
Reloading systemctl daemon
Starting webmin service
Failed to start webmin.service: Unit webmin.service not found.
Done!
App: Webmin installed
======= app install end @ 2019-02-06 15:20:03 -0600 ==========

with cached file removed before install:

======= app install begin @ 2019-02-06 16:58:58 -0600 ==========
Installing app id uicm8zt4hf under /var/hda/platform/html/script/.. ENV=production
NOTICE: redirected 'https://downloads.sourceforge.net/proje ... noarch.rpm' --> 'https://newcontinuum.dl.sourceforge.net ... noarch.rpm' ...
file /var/hda/tmp/amahi-download-cache/189587329ebd2783456b06e6d9604ba8938cf393 written in cache
Your HDA services have been restarted.
Your HDA services have been restarted.
Enabling webmin service
Failed to enable unit: Unit file webmin.service does not exist.
Configuring Amahi settings
/var/hda/web-apps/webmin/elevated/start.sh: line 4: /etc/webmin/config: No such file or directory
sed: can't read /etc/webmin/miniserv.conf: No such file or directory
sed: can't read /etc/webmin/miniserv.conf: No such file or directory
Reloading systemctl daemon
Starting webmin service
Failed to start webmin.service: Unit webmin.service not found.
Done!
App: Webmin installed
======= app install end @ 2019-02-06 16:59:05 -0600 ==========

Thanks

User avatar
bigfoot65
Project Manager
Posts: 11441
Joined: Mon May 25, 2009 4:31 pm

Re: Webmin installation problem on Amahi 11

Postby bigfoot65 » Wed Feb 06, 2019 4:06 pm

Try uninstall, the reinstall.

I just tested the app and worked fine for me.

Did you make any manual configuration changes? Seems odd that it doesn’t install correctly for you.

Could have something to do with the Express CD.

Ensure you do the OS updates.
ßîgƒσστ65
Applications Manager

gwynap
Posts: 11
Joined: Wed Feb 06, 2019 11:23 am

Re: Webmin installation problem on Amahi 11

Postby gwynap » Wed Feb 06, 2019 4:23 pm

Thanks for the advice ... I've tried your suggestions and still no luck. I haven't made any manual config changes. I could try restarting the HDA.

Regarding the Express CD, would you recommend re-installing using a different method, e.g. Minimal CD? It's a bit of work but doable.

User avatar
bigfoot65
Project Manager
Posts: 11441
Joined: Mon May 25, 2009 4:31 pm

Re: Webmin installation problem on Amahi 11

Postby bigfoot65 » Wed Feb 06, 2019 4:45 pm

Try restarting.

Not sure why there’s an issue using Express CD.
ßîgƒσστ65
Applications Manager

gwynap
Posts: 11
Joined: Wed Feb 06, 2019 11:23 am

Re: Webmin installation problem on Amahi 11

Postby gwynap » Fri Feb 08, 2019 10:32 am

Reinstalled using Minimal CD rather than Express. Installed Webmin first and it works.

User avatar
bigfoot65
Project Manager
Posts: 11441
Joined: Mon May 25, 2009 4:31 pm

Re: Webmin installation problem on Amahi 11

Postby bigfoot65 » Fri Feb 08, 2019 5:46 pm

Cool. Odd that it didn’t work with Express CD.

Marking topic closed.
ßîgƒσστ65
Applications Manager

genel
Posts: 56
Joined: Mon Oct 22, 2012 5:10 pm

Re: CLOSED: Webmin installation problem on Amahi 11

Postby genel » Wed Mar 20, 2019 8:17 pm

I have this problem. Nothing for webmin gets installed. The web-apps/webmin directory and the html and logs directories are there but its all empty. The is no webmin.service anywhere. Any suggestions on how to proceed?

Gene

User avatar
bigfoot65
Project Manager
Posts: 11441
Joined: Mon May 25, 2009 4:31 pm

Re: CLOSED: Webmin installation problem on Amahi 11

Postby bigfoot65 » Thu Mar 21, 2019 3:42 am

Please start a new thread. This one is closed.

Also provide the URl for:

Code: Select all

apaste --sysinfo
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 4 guests