Web App getting redirected to amahi.org control panel

lancaster71
Posts: 20
Joined: Thu Sep 06, 2012 8:44 am

Web App getting redirected to amahi.org control panel

Postby lancaster71 » Tue Dec 13, 2016 4:32 pm

I am running Amahi 9 on Fedora 23.

I created a web app and put a basic index.html page in the html folder for testing. When trying to access it with the internal url, the browser has a message in the top left corner: "This site is a repository, please see the Amahi web site at http://www.amahi.org" on an otherwise blank page and then goes to the amahi.org/users control panel page. All the other applications I installed are working fine, like wordpress, phpmyadmin, owncloud9, pydio, etc.

I've tried creating web apps with different names and rebooting. I also didn't see a relevant forum post for this, sorry if I missed that.

the apaste --sysinfo:
http://paste.fedoraproject.org/505981/16714361/ -> https://paste.fedoraproject.org/505981/16714361

Thanks for any help!

User avatar
bigfoot65
Project Manager
Posts: 11191
Joined: Mon May 25, 2009 4:31 pm

Re: Web App getting redirected to amahi.org control panel

Postby bigfoot65 » Tue Dec 13, 2016 4:59 pm

What guidance did you follow for creating the app?

Might try:

Code: Select all

sudo systemctl restart httpd
Ensure you use the URL with a trailing slash. For example http://app/
ßîgƒσστ65
Applications Manager

lancaster71
Posts: 20
Joined: Thu Sep 06, 2012 8:44 am

Re: Web App getting redirected to amahi.org control panel

Postby lancaster71 » Wed Dec 14, 2016 10:57 am

Code: Select all

sudo systemctl restart http
gave me an error, so I restarted httpd. Even with the trailing / same issue.

I installed the Web Apps app from the control panel then used the "New Web App" button to create the app.

User avatar
bigfoot65
Project Manager
Posts: 11191
Joined: Mon May 25, 2009 4:31 pm

Re: Web App getting redirected to amahi.org control panel

Postby bigfoot65 » Wed Dec 14, 2016 1:13 pm

gave me an error, so I restarted httpd. Even with the trailing / same issue.
Yea sorry about that, I left off the d.
I installed the Web Apps app from the control panel then used the "New Web App" button to create the app.
The ownership permissions of the file you created must be apache:users. If that is not the case, do the following from the directory:

Code: Select all

chown apache:users index.html
ßîgƒσστ65
Applications Manager

lancaster71
Posts: 20
Joined: Thu Sep 06, 2012 8:44 am

Re: Web App getting redirected to amahi.org control panel

Postby lancaster71 » Wed Dec 14, 2016 5:28 pm

Dang, I was hoping that was it, still having the issue.

I tried giving the app directory and html also to apache:users and changed the permissions to 0777 for all of them just to see if that might have been it too. Still same thing.

User avatar
bigfoot65
Project Manager
Posts: 11191
Joined: Mon May 25, 2009 4:31 pm

Re: Web App getting redirected to amahi.org control panel

Postby bigfoot65 » Wed Dec 14, 2016 5:36 pm

Did you make any manual changes to the virtual host file or the HDA itself?

It should work otherwise.
ßîgƒσστ65
Applications Manager

lancaster71
Posts: 20
Joined: Thu Sep 06, 2012 8:44 am

Re: Web App getting redirected to amahi.org control panel

Postby lancaster71 » Wed Dec 14, 2016 5:50 pm

I made some manual changes to the ssh config file, added some external links to the config files for a couple apps, added a user to the wordpress database using phpmyadmin, changed a setting on the owncloud9 config, installed java, openssl, screen, rsnapshot, and bind utils. Other than that, the apps I installed were from the hda control panel.

lancaster71
Posts: 20
Joined: Thu Sep 06, 2012 8:44 am

Re: Web App getting redirected to amahi.org control panel

Postby lancaster71 » Sun Dec 18, 2016 9:25 am

Tried a fresh install of Amahi and I still keep getting redirected from the webapps site. After getting Amahi installed, webapps was the first thing I set up before anything else.

I also just put the html/index.html file I was using for the webapps app into the wordpress app folder and that worked just fine.

User avatar
bigfoot65
Project Manager
Posts: 11191
Joined: Mon May 25, 2009 4:31 pm

Re: Web App getting redirected to amahi.org control panel

Postby bigfoot65 » Sun Dec 18, 2016 9:59 am

I also just put the html/index.html file I was using for the webapps app into the wordpress app folder and that worked just fine.
That indicates there is a problem with the apache virtual host file.

Post the contents of /etc http/conf.d/####-webappname.conf. Replace webappname with the name of your web app and #### should correspond to the auto generated number.

You can do:

Code: Select all

ls -al /etc/http/conf.d
to see the file name.

Check /var/log/amahi-app-installer.log for errors.
ßîgƒσστ65
Applications Manager

lancaster71
Posts: 20
Joined: Thu Sep 06, 2012 8:44 am

Re: Web App getting redirected to amahi.org control panel

Postby lancaster71 » Sat Dec 24, 2016 8:15 pm

There didn't seem to be any errors in the logfile. All the apps that were installed, including the webapps had identical info.

This is the conf.d file for the "website" app that I tried to make:

Code: Select all

<VirtualHost *:80> ServerName website ServerAlias website.amahi.net DocumentRoot /var/hda/web-apps/website/html <Directory "/var/hda/web-apps/website/html"> Options Indexes FollowSymLinks MultiViews <If "-s '/var/hda/web-apps/website/htpasswd'"> AuthType Basic AuthName "User Login Required for This Area" AuthUserFile /var/hda/web-apps/website/htpasswd Require valid-user </If> <Else> AllowOverride AuthConfig Require all granted </Else> </Directory> ErrorLog /var/hda/web-apps/website/logs/error_log CustomLog /var/hda/web-apps/website/logs/access_log combined env=!dontlog </VirtualHost>

Who is online

Users browsing this forum: No registered users and 2 guests