Guacamole Resurrected

rdagijones
Posts: 262
Joined: Thu Jan 26, 2012 7:56 am

Re: Guacamole Resurrected

Postby rdagijones » Tue Oct 18, 2016 6:28 am

When I tried to download the install script from terminal I got the following:
file /var/hda/tmp/amahi-download-cache/d5c16b482f33ad9c046fc2876cfa38f184ac9a8b written in cache
WARNING: primary downloaded file /var/hda/tmp/amahi-download-cache/d5c16b482f33ad9c046fc2876cfa38f184ac9a8b did not pass signature check - got 7cf3a9062d4345a37f5fc8536c7918b4432f80eb, expected d5c16b482f33ad9c046fc2876cfa38f184ac9a8b
new file /var/hda/tmp/amahi-download-cache/d5c16b482f33ad9c046fc2876cfa38f184ac9a8b from Amahi's mirror written in the cache
/usr/bin/amahi-download:134:in `download': http://mirror.amahi.org/d5c16b482f33ad9 ... f184ac9a8b (from original https://www.dropbox.com/s/4hadafih8ahuj ... acamole.sh), '95a7e2e0ccea21868c9cc1f746cf9811c164d5c9' vs. 'd5c16b482f33ad9c046fc2876cfa38f184ac9a8b' (Downloader::SHA1VerificationFailed)
from /usr/bin/amahi-download:80:in `download_and_check_sha1'
from /usr/bin/amahi-download:166:in `main'
from /usr/bin/amahi-download:173:in `<main>'
I just went to the site and copied / pasted the script to make it happen.

rdagijones
Posts: 262
Joined: Thu Jan 26, 2012 7:56 am

Re: Guacamole Resurrected

Postby rdagijones » Tue Oct 18, 2016 7:25 am

Also, guacd is running but I am getting a blank screen at localhost:8080/guacamole. I have been working my way in pieces through the commands of the script in terminal and get the following error:
warning: libxkbfile-1.0.8-5.el7.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID f4a80eb5: NOKEY
error: Failed dependencies:
libxkbfile = 1.0.9-2.fc23 is needed by (installed) libxkbfile-devel-1.0.9-2.fc23.x86_64
What is libxkbfile and why is it needed?

Granted some of these issues may be because this is not a clean install. I am trying to troubleshoot it. What log file do you think I should investigate? There are no entries in the error_log in /var/hda/web-apps/guacamole/logs and access_log is this:
- - [18/Oct/2016:09:50:24 -0400] "GET / HTTP/1.1" 404 - "-" "Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0"
I took the ip of the server out of the beginning of the quote.

User avatar
bigfoot65
Project Manager
Posts: 11029
Joined: Mon May 25, 2009 4:31 pm

Re: Guacamole Resurrected

Postby bigfoot65 » Tue Oct 18, 2016 7:44 am

As for the failed download, I am going to just change it to wget to keep it simple.
What is libxkbfile and why is it needed?
It's required by the other two CentOS packages. Since you already have the F23 version installed, it failed. This script should really be run on a clean install.

If you want to start over with the install script, ensure the freerdp packages and the libxkbfile are removed before you run it. Those 3 files have to install in the order listed or the rest of the install will likely fail.
ßîgƒσστ65
Applications Manager

rdagijones
Posts: 262
Joined: Thu Jan 26, 2012 7:56 am

Re: Guacamole Resurrected

Postby rdagijones » Tue Oct 18, 2016 8:10 am

I found my big roadblock. I had tried installing the 0.9.8 rpm version on this particular computer and it did not work. I removed the rpm and things seem to be resolving correctly.

User avatar
bigfoot65
Project Manager
Posts: 11029
Joined: Mon May 25, 2009 4:31 pm

Re: Guacamole Resurrected

Postby bigfoot65 » Tue Oct 18, 2016 10:28 am

Awesome!

I did an RDP connection last night with my Laptop which has Windows 10 Pro on it. Worked :D
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 1 guest