SOLVED: Webmin does not login after first install

lokeshchdhry
Posts: 6
Joined: Thu Aug 11, 2016 3:54 pm

SOLVED: Webmin does not login after first install

Postby lokeshchdhry » Thu Aug 11, 2016 8:21 pm

Hi All,
I installed amahi 9 & installed webmin app, but when I try to login with Username: root & Password: (my root password or fedora password) it gives me login failed.
I uninstalled & installed webmin to rule out bad installation again but still nothing.

What am I doing wrong here ?


Thanks.

User avatar
bigfoot65
Project Manager
Posts: 11301
Joined: Mon May 25, 2009 4:31 pm

Re: Webmin does not login after first install

Postby bigfoot65 » Fri Aug 12, 2016 5:40 am

Did you set a root password when installing Fedora? If not, try your first admin user name and password.

Please let us know if that works.
ßîgƒσστ65
Applications Manager

lokeshchdhry
Posts: 6
Joined: Thu Aug 11, 2016 3:54 pm

Re: Webmin does not login after first install

Postby lokeshchdhry » Fri Aug 12, 2016 11:32 am

No I did not create a root password as the setup wiki https://wiki.amahi.org/index.php/Amahi_9_Install says not to.
I only have one user which is the admin & it does not work with webmin. I can login as root in the hda text console using "sudo su -".

User avatar
bigfoot65
Project Manager
Posts: 11301
Joined: Mon May 25, 2009 4:31 pm

Re: Webmin does not login after first install

Postby bigfoot65 » Fri Aug 12, 2016 1:22 pm

I only have one user which is the admin & it does not work with webmin.
Probably the easiest fix is to create a root password. To do so, do the following:

Code: Select all

sudo su - passwd
Once finished, try logging into webmin App as root with the new password.
ßîgƒσστ65
Applications Manager

lokeshchdhry
Posts: 6
Joined: Thu Aug 11, 2016 3:54 pm

Re: Webmin does not login after first install

Postby lokeshchdhry » Fri Aug 12, 2016 2:26 pm

Ok bigfoot65 let me try that.

lokeshchdhry
Posts: 6
Joined: Thu Aug 11, 2016 3:54 pm

Re: Webmin does not login after first install

Postby lokeshchdhry » Fri Aug 12, 2016 2:38 pm

Do I have to give any username after passwd like

Code: Select all

passwd root
or

Code: Select all

sudo su -
will take care of it ?

User avatar
bigfoot65
Project Manager
Posts: 11301
Joined: Mon May 25, 2009 4:31 pm

Re: Webmin does not login after first install

Postby bigfoot65 » Fri Aug 12, 2016 5:56 pm

Just enter the commands as I specified.

The password you set will be for root.
ßîgƒσστ65
Applications Manager

lokeshchdhry
Posts: 6
Joined: Thu Aug 11, 2016 3:54 pm

Re: Webmin does not login after first install

Postby lokeshchdhry » Sat Aug 13, 2016 5:07 pm

Thanks it worked.

User avatar
bigfoot65
Project Manager
Posts: 11301
Joined: Mon May 25, 2009 4:31 pm

Re: Webmin does not login after first install

Postby bigfoot65 » Sat Aug 13, 2016 5:24 pm

Good to hear.

Marking as solved.
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 1 guest