SOLVED: qBittorrent not working

rdagijones
Posts: 270
Joined: Thu Jan 26, 2012 7:56 am

SOLVED: qBittorrent not working

Postby rdagijones » Sun Jan 03, 2016 2:54 pm

Installed qBittorrent today and page that comes up says "Service Unavailable. The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later." On the dashboard, under Settings > Servers, qBittorrent Server is stopped. I did a little poking around and found that the /var/hda/web-apps/qbittorrent/html folder is empty. Is it suppose to be that way?

User avatar
bigfoot65
Project Manager
Posts: 11419
Joined: Mon May 25, 2009 4:31 pm

Re: qBittorrent not working

Postby bigfoot65 » Sun Jan 03, 2016 3:18 pm

Yes as it's an RPM install.

Check the Amahi app install log for errors.
ßîgƒσστ65
Applications Manager

rdagijones
Posts: 270
Joined: Thu Jan 26, 2012 7:56 am

Re: qBittorrent not working

Postby rdagijones » Sun Jan 03, 2016 6:26 pm

Would you remind me of the location of that log?

User avatar
bigfoot65
Project Manager
Posts: 11419
Joined: Mon May 25, 2009 4:31 pm

Re: qBittorrent not working

Postby bigfoot65 » Sun Jan 03, 2016 6:33 pm

See Common Log Files in the wiki.

BTW, I did a test install and worked fine for me.
ßîgƒσστ65
Applications Manager

rdagijones
Posts: 270
Joined: Thu Jan 26, 2012 7:56 am

Re: qBittorrent not working

Postby rdagijones » Sun Jan 03, 2016 7:49 pm

Ok. Looked at amahi-app-installer.log file and got this:
sed: can't read /usr/lib/systemd/system/qbittorrent-nox.service: No such file or directory
Reload systemctl daemon
Enabling qbittorrent.service
Failed to execute operation: No such file or directory
Starting qbittorrent.service
Failed to start qbittorrent-nox.service: Unit qbittorrent-nox.service failed to load: No such file or directory.
App: qBittorrent installed

User avatar
bigfoot65
Project Manager
Posts: 11419
Joined: Mon May 25, 2009 4:31 pm

Re: qBittorrent not working

Postby bigfoot65 » Mon Jan 04, 2016 11:55 am

Looks like the install did not complete successfully.

Have you installed this app before? Did you make any manual changes?

What is the result of:

Code: Select all

yum list qbittorrent-nox
ßîgƒσστ65
Applications Manager

TaurusPTC
Posts: 1
Joined: Sat Jan 16, 2016 12:58 pm

Re: qBittorrent not working

Postby TaurusPTC » Sat Jan 16, 2016 1:35 pm

Hello Bigfoot65 & rdagijones

I had the same error after a installing Qbittorrent on a clean install of Amahi 8.

My logs showed that the app did install, but the following error occurred:

Failed to start qbittorrent-nox.service: Unit qbittorrent-nox.service failed to load: No such file or directory.

As Bigfoot65 mentioned in the last post, I ran 'yum list qbittorrent-nox' and got the following response:

[root@localhost etc]# yum list qbittorrent-nox
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
* fedora: repo.atlantic.net
* rpmfusion-free: mirror.us.leaseweb.net
* rpmfusion-free-updates: mirror.us.leaseweb.net
* rpmfusion-nonfree: mirror.us.leaseweb.net
* rpmfusion-nonfree-updates: mirror.us.leaseweb.net
* updates: repo.atlantic.net
Available Packages
qbittorrent-nox.x86_64 1:3.2.4-2.fc21 updates

I ran yum install qbittorrent-nox.x.86_64 which installed the files.
Once the process was completed, I did a systemctl restart qbittorrent-nox.service
Went back to the dashboard, clicked the Qbittorrent icon and the app launched.

All good now :)

User avatar
bigfoot65
Project Manager
Posts: 11419
Joined: Mon May 25, 2009 4:31 pm

Re: qBittorrent not working

Postby bigfoot65 » Sat Jan 16, 2016 5:00 pm

Good to hear it's working.

Will close this as solved.
ßîgƒσστ65
Applications Manager

rdagijones
Posts: 270
Joined: Thu Jan 26, 2012 7:56 am

Re: SOLVED: qBittorrent not working

Postby rdagijones » Wed Jan 20, 2016 9:11 pm

Error: Package: 1:qbittorrent-nox-3.3.1-2.el7.x86_64 (epel)
Requires: libboost_system.so.1.53.0()(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
This is the error I get every time I try to install qbittorrent-nox. I have tried researching it and really get nowhere. Any ideas?

User avatar
bigfoot65
Project Manager
Posts: 11419
Joined: Mon May 25, 2009 4:31 pm

Re: SOLVED: qBittorrent not working

Postby bigfoot65 » Thu Jan 21, 2016 3:36 am

Error: Package: 1:qbittorrent-nox-3.3.1-2.el7.x86_64 (epel)
Your issue is you have the EPEL repo installed and it's trying to pull the package from there.

The app must use the Fedora 21 repo. Receommend you disable/uninstall the EPEL repo and then try.
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 1 guest