Headphones SSL Issue

phreaq
Posts: 87
Joined: Sun Jul 20, 2014 10:39 am

Headphones SSL Issue

Postby phreaq » Tue May 26, 2015 1:40 pm

I posted the below message to the Headphones github;

Code: Select all

I am getting various errors when searching fro my wanted albums, with a different error for each provider. When searching KAT, I get: [quote]Request raise HTTP error with status code 404 (local client error).[/quote] Searching TPB [quote]SSL error raised during connection, with certificate verification turned off: [Errno 1] _ssl.c:504: error:14077438:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert internal error[/quote] and my nzb provider [quote]Request raise HTTP error with status code 429 (local client error).[/quote] What's odd is, some albums are being snatched. I am able to access all these site manually, and thru other apps like SickRage. I have edited my config.ini to include the 'verify_cert_ssl to 0', and my Headphones is up to date. Any thoughts on the issue?
which they closed, and pointed to (https://github.com/rembo10/headphones/issues/2210) which discuss SSL issues as being the cause.

that thread points to a SickRage thread (https://github.com/SiCKRAGETV/sickrage- ... SSL-Errors) which discuss a possible solution.

The code they have is not Amahi-friendly (well, not to me), has anyone else had issues lately?

phreaq
Posts: 87
Joined: Sun Jul 20, 2014 10:39 am

Re: Headphones SSL Issue

Postby phreaq » Mon Jun 08, 2015 7:00 am

so nobody else has this issue? darn :(

it seems my issue is tied to this (https://github.com/rembo10/headphones/w ... -dont-work)

I made the .ini settings change (although it's called headphones.ini on our installs), but I don't now about the other items (enable sni, install certificate)

Who is online

Users browsing this forum: No registered users and 1 guest