CLOSED: Remote Wake-On-LAN Server

rdagijones
Posts: 265
Joined: Thu Jan 26, 2012 7:56 am

Re: Remote Wake-On-LAN Server

Postby rdagijones » Wed Feb 04, 2015 7:12 am

Made the Listen 8081 change on one test server and things seems to work fine. I could get to wolserver in the network and add machines and users. It's been a day or two and now all of my apps do not resolve correctly. I ran Amahi's Interactive Network Troubleshooter and came up with the error: "** server can't find hda: NXDOMAIN" The only other change I can think of that I made to that server is this morning I installed Webmin from the .rpm on the Webmin site.

How do I troubleshoot "** server can't find hda: NXDOMAIN?"

User avatar
bigfoot65
Project Manager
Posts: 11186
Joined: Mon May 25, 2009 4:31 pm

Re: Remote Wake-On-LAN Server

Postby bigfoot65 » Wed Feb 04, 2015 2:36 pm

I have discovered a minor change to the procedure for running apps on a different port. Rather than modify /etc/httpd/conf/httpd.conf, you can do the following for the app:
Listen 8081
<VirtualHost *:8081>
Adding the line as the first line in the ###-appname.conf file works the same as adding it to httpd.conf. This is a cleaner way to do it and will ensure if you don't want an app on a port, httpd is not listening on the port. Always best to not modify httpd.conf file as it could break the web server.

Does that make sense?

As for you current problem, recommend you check the client DNS to ensure it's using the HDA. For a Windows machine, just do:

Code: Select all

ipconfig /all
ßîgƒσστ65
Applications Manager

rdagijones
Posts: 265
Joined: Thu Jan 26, 2012 7:56 am

Re: Remote Wake-On-LAN Server

Postby rdagijones » Wed Feb 04, 2015 2:39 pm

Actually, I cannot get the apps to resolve even on the server, The warning that I posted is on the Amahi server. Something is off with the DNS of the server. How do I troubleshoot this?

rdagijones
Posts: 265
Joined: Thu Jan 26, 2012 7:56 am

Re: Remote Wake-On-LAN Server

Postby rdagijones » Wed Feb 04, 2015 2:41 pm

OK, I changed the /etc/httpd/conf/httpd.conf and dropped the Listen 8081 and things are back as they should be. I will try the other method that you have mentioned. Lets see. :-)

User avatar
bigfoot65
Project Manager
Posts: 11186
Joined: Mon May 25, 2009 4:31 pm

Re: Remote Wake-On-LAN Server

Postby bigfoot65 » Wed Feb 04, 2015 2:45 pm

It works. I did test it :)

I still have not added the wiki guidance yet. It's on my list.

As for you other issue, verify the DNS server is enabled and running on the HDA. It's in the Dashboard under Network, Settings.
ßîgƒσστ65
Applications Manager

rdagijones
Posts: 265
Joined: Thu Jan 26, 2012 7:56 am

Re: Remote Wake-On-LAN Server

Postby rdagijones » Wed Feb 04, 2015 8:46 pm

Nice icon and screen capture added to the App. Where did you get the icon? I like it.

I updated the WOL wiki. Feel free to adjust it as needed.

User avatar
bigfoot65
Project Manager
Posts: 11186
Joined: Mon May 25, 2009 4:31 pm

Re: Remote Wake-On-LAN Server

Postby bigfoot65 » Thu Feb 05, 2015 3:36 am

Google :D

Once you finish your testing, we should be able to release this one LIVE.

Thanks for making the updates and I will check out the wiki guidance.
ßîgƒσστ65
Applications Manager

User avatar
bigfoot65
Project Manager
Posts: 11186
Joined: Mon May 25, 2009 4:31 pm

Re: Remote Wake-On-LAN Server

Postby bigfoot65 » Thu Feb 05, 2015 5:10 pm

Made updates to the wiki guidance. I also have put the new instructions for exposing web apps to the internet at Hosting Webapps (Alternative).

This gives users a choice and keeps duplication of guidance to a minimum.
ßîgƒσστ65
Applications Manager

rdagijones
Posts: 265
Joined: Thu Jan 26, 2012 7:56 am

Re: Remote Wake-On-LAN Server

Postby rdagijones » Thu Feb 05, 2015 7:40 pm

I have tested the VirtualHost method of changing httpd.conf and had problems on both servers. The method of changing the .conf file for the app seems stable. I want to run it for a few more days and see what happens. Good work.

User avatar
bigfoot65
Project Manager
Posts: 11186
Joined: Mon May 25, 2009 4:31 pm

Re: Remote Wake-On-LAN Server

Postby bigfoot65 » Thu Feb 05, 2015 8:02 pm

I was afraid that might happen. Not a big fan of editing httpd.conf so that's why I came up with the other method. It should prove solid.

Good work by all.

I would like to see the web UI spruced up a bit though. I think adding buttons vs links for the menus would be nicer. Did you check out the sceen shots from the AMS app that I uploaded earlier a while back?

Adding buttons is not too hard in php :)
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 3 guests