Possible App?

rdagijones
Posts: 270
Joined: Thu Jan 26, 2012 7:56 am

Possible App?

Postby rdagijones » Sat Oct 04, 2014 9:33 pm

I have a customer that I have been trying to talk into using Amahi for other needs. He has just approached me about wanting to use the following program (http://www.projectfedena.org/install) in his school. I think I could open him up to the other possibilities of Amahi if I could set up Fedena up on an Amahi 7/Fedora 19 machine. Does anyone see any complications I may run into trying to set up Fedena as an app on Amahi? I have set up other web apps before that were not one-click and they work for me.

User avatar
bigfoot65
Project Manager
Posts: 11450
Joined: Mon May 25, 2009 4:31 pm

Re: Possible App?

Postby bigfoot65 » Sun Oct 05, 2014 5:33 pm

I am sure it's possible. You can suggest it here for Amahi:

Suggest

If you do it yourself and document the steps, we could possibly make it an Amahi app sooner.
ßîgƒσστ65
Applications Manager

rdagijones
Posts: 270
Joined: Thu Jan 26, 2012 7:56 am

Re: Possible App?

Postby rdagijones » Mon Oct 06, 2014 3:28 am

How can I check to see of there are any dependencies for this program? (My terminal commands are patchy at best.) I can see that ruby and rails are in the instructions (which I know are already part of Amahi 7.) But there is also rubygems. I think this is there but how do I validate it? Forgive my ignorance but at least I am bold enough to learn :D .

User avatar
bigfoot65
Project Manager
Posts: 11450
Joined: Mon May 25, 2009 4:31 pm

Re: Possible App?

Postby bigfoot65 » Mon Oct 06, 2014 1:04 pm

Most likely you will have to install the correct gems. I'd look for some instructions on how to install. It's ok if it's not for Fedora as they are often easy to convert to a different OS.
ßîgƒσστ65
Applications Manager

rdagijones
Posts: 270
Joined: Thu Jan 26, 2012 7:56 am

Re: Possible App?

Postby rdagijones » Fri Oct 24, 2014 7:35 pm

I think I have found the problem:

Fedena requires:
ruby 1.8.7-p371
and
rubygems 1.3.7

When I attempt to install one of them (I cannot remember which one, but I think it is ruby) I have to uninstall it first. The uninstall removes either "hda-ctl" or "hda-platform." When I reinstall the hda packages, a more current version of ruby and rubygems is installed.

Any ideas?

User avatar
bigfoot65
Project Manager
Posts: 11450
Joined: Mon May 25, 2009 4:31 pm

Re: Possible App?

Postby bigfoot65 » Sat Oct 25, 2014 8:08 am

Not good with Ruby. It can be a pain. Your best bet is looking on the internet or a solution. Since Amahi is based on Ruby, recommend extreme caution as you can break your HDA.
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 2 guests