OpenVPN ALS Stopped

rdagijones
Posts: 265
Joined: Thu Jan 26, 2012 7:56 am

OpenVPN ALS Stopped

Postby rdagijones » Thu Jul 10, 2014 5:57 pm

I have my home server and then I have set up Amahi servers for a few organizations. I recently upgraded all of them to Amahi 7 on Fedora 19. I have installed the OpenVPN and OpenVPN ALS apps. Now every one of the servers I manage say that the OpenVPN server has stopped. I believe this is also causing the OpenVPN ALS app to fail to work as well. Anyone know what is going on? :?

User avatar
bigfoot65
Project Manager
Posts: 11296
Joined: Mon May 25, 2009 4:31 pm

Re: OpenVPN Stopped

Postby bigfoot65 » Thu Jul 10, 2014 6:36 pm

Execute the following command and post the results:

Code: Select all

systemctl status openvpn@amahi.service
If it shows running, your problem may be firewall or ISP related.
ßîgƒσστ65
Applications Manager

rdagijones
Posts: 265
Joined: Thu Jan 26, 2012 7:56 am

Re: OpenVPN Stopped

Postby rdagijones » Thu Jul 10, 2014 6:53 pm

I will post those results a.s.a.p.

Funny thing is all I did was upgrade from Fedora 14 to 19 and then from Amahi 6 to Amahi 7. Everything else in my network is exactly the same and no change in ISP. OpenVPN worked before the upgrade.

User avatar
bigfoot65
Project Manager
Posts: 11296
Joined: Mon May 25, 2009 4:31 pm

Re: OpenVPN Stopped

Postby bigfoot65 » Thu Jul 10, 2014 7:04 pm

Did you create new profiles on amahi.org or use the Fedora 14 existing ones?

If you used the existing ones, that may be part of your issue. We recommend generating new profiles as there are some things behind the scenes that have changed since Amahi 6 on Fedora 14 was released.
ßîgƒσστ65
Applications Manager

rdagijones
Posts: 265
Joined: Thu Jan 26, 2012 7:56 am

Re: OpenVPN Stopped

Postby rdagijones » Fri Jul 11, 2014 4:06 am

Oh my. I did use an existing profile. How on earth do I fix that?!

User avatar
bigfoot65
Project Manager
Posts: 11296
Joined: Mon May 25, 2009 4:31 pm

Re: OpenVPN Stopped

Postby bigfoot65 » Fri Jul 11, 2014 6:53 am

You would have to start over. No guarantee that's the issue. What is the result of the command I posted previously?

[ Post made via Android ] Image
ßîgƒσστ65
Applications Manager

rdagijones
Posts: 265
Joined: Thu Jan 26, 2012 7:56 am

Re: OpenVPN Stopped

Postby rdagijones » Fri Jul 11, 2014 7:27 am

Here are the results from one of the servers when I run

Code: Select all

systemctl status openvpn@amahi.service
openvpn@amahi.service - OpenVPN Robust And Highly Flexible Tunneling Application On amahi
Loaded: loaded (/usr/lib/systemd/system/openvpn@.service; enabled)
Active: active (running) since Tue 2014-07-01 12:51:29 EDT; 1 weeks 2 days ago
Main PID: 809 (openvpn)
CGroup: name=systemd:/system/openvpn@.service/openvpn@amahi.service
├─717 /usr/sbin/openvpn --daemon --writepid /var/run/openvpn/amahi...
└─809 /usr/sbin/openvpn --daemon --writepid /var/run/openvpn/amahi...

Jul 01 12:51:26 ciserver.home.com openvpn[671]: /usr/sbin/ip addr add dev tu...2
Jul 01 12:51:26 ciserver.home.com openvpn[671]: ./amahi.up tun0 1500 1542 10...t
Jul 01 12:51:29 ciserver.home.com openvpn[671]: /usr/sbin/ip route add 10.8....2
Jul 01 12:51:29 ciserver.home.com systemd[1]: Started OpenVPN Robust And Hig....
Jul 01 12:51:29 ciserver.home.com openvpn[809]: UDPv4 link local (bound): [u...]
Jul 01 12:51:29 ciserver.home.com openvpn[809]: UDPv4 link remote: [undef]
Jul 01 12:51:29 ciserver.home.com openvpn[809]: MULTI: multi_init called, r=...6
Jul 01 12:51:29 ciserver.home.com openvpn[809]: IFCONFIG POOL: base=10.8.0.4...0
Jul 01 12:51:29 ciserver.home.com openvpn[809]: IFCONFIG POOL LIST
Jul 01 12:51:29 ciserver.home.com openvpn[809]: Initialization Sequence Comp...d

User avatar
bigfoot65
Project Manager
Posts: 11296
Joined: Mon May 25, 2009 4:31 pm

Re: OpenVPN Stopped

Postby bigfoot65 » Fri Jul 11, 2014 12:57 pm

Shows it's running, so your issue is not the VPN. It is either a firewall, ISP, or something else blocking the connection.
ßîgƒσστ65
Applications Manager

rdagijones
Posts: 265
Joined: Thu Jan 26, 2012 7:56 am

Re: OpenVPN Stopped

Postby rdagijones » Fri Jul 11, 2014 1:45 pm

If it is working why does OpenVPN ALS also say that its service is stopped on the Amahi web dashboard?

User avatar
bigfoot65
Project Manager
Posts: 11296
Joined: Mon May 25, 2009 4:31 pm

Re: OpenVPN Stopped

Postby bigfoot65 » Fri Jul 11, 2014 2:13 pm

That is a different app, a clientless VPN. They are not one in the same.

It may not be running. To check it, you need to do:

Code: Select all

service status adito
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 3 guests