Monit Service Manager problem

jehali
Posts: 48
Joined: Thu Oct 06, 2011 10:37 am

Monit Service Manager problem

Postby jehali » Thu Oct 11, 2018 1:02 am

After installing Monit , I got at first a 503 error, but in /etc/monit.d/localhost.conf I did comment the following lines:
set mailformat unto message ....
After that I was able to login.
But the monitoring of nfs service and ntpd service gives errors.
In /var/run are the files nfs.pid and ntpd.pid not present.

I know it is quite old, but is there a solutions for this?


(Paste) : https://paste.fedoraproject.org/paste/q ... ~FkSNAV5gQ

User avatar
bigfoot65
Project Manager
Posts: 11096
Joined: Mon May 25, 2009 4:31 pm

Re: Monit Service Manager problem

Postby bigfoot65 » Thu Oct 11, 2018 2:33 pm

Is this a new install of Amahi?

Are you using Amahi for your DHCP and DNS Server?

I have tested this app many times and have no issues.

As for the apps not providing PID files, I know OpenVPN does. Might try uninstalling and reinstalling the app.
ßîgƒσστ65
Applications Manager

jehali
Posts: 48
Joined: Thu Oct 06, 2011 10:37 am

Re: Monit Service Manager problem

Postby jehali » Fri Oct 12, 2018 4:25 am

Uninstalling and reinstalling the apps Monit, Network Time did the job.
Fixing uninstalling and reinstalling NFS via the dashboard did not work until now. Any suggestions?

User avatar
bigfoot65
Project Manager
Posts: 11096
Joined: Mon May 25, 2009 4:31 pm

Re: Monit Service Manager problem

Postby bigfoot65 » Fri Oct 12, 2018 7:15 am

Are you using Amahi 10 or 11?

nfs App is not LIVE for Amahi 11.

Please check /var/log/amahi-app-installer.log file for errors.

Sometimes Fedora updates fix or break the PID generation. Have you updated the OS?
ßîgƒσστ65
Applications Manager

jehali
Posts: 48
Joined: Thu Oct 06, 2011 10:37 am

Re: Monit Service Manager problem

Postby jehali » Fri Oct 12, 2018 7:35 am

I am using Amahi 11

nfs App is not LIVE for Amahi 11.

Thats the problem....
Waiting for becoming ALIVE !!
Thanks

User avatar
bigfoot65
Project Manager
Posts: 11096
Joined: Mon May 25, 2009 4:31 pm

Re: Monit Service Manager problem

Postby bigfoot65 » Fri Oct 12, 2018 10:05 am

Did you do a new install or upgrade?

Just trying to determine how you had issues.

Most of these apps have been tested on Fedora 27 and there were no issues.
ßîgƒσστ65
Applications Manager

jehali
Posts: 48
Joined: Thu Oct 06, 2011 10:37 am

Re: Monit Service Manager problem

Postby jehali » Fri Oct 12, 2018 10:30 am

I did an upgrade from Amahi 10 to 11
We shortrly discussed some issues, but these are solved.
As you mentioned nfs is still not LIVE for Amahi 11, so I will wait unto that moment.
BTW: NFS server is running well under Fedora 27 yet.
The only problem is that nfs.service is not creating a nfs.pid file in /var/run/.
But maybe I can handle that in another way.

User avatar
bigfoot65
Project Manager
Posts: 11096
Joined: Mon May 25, 2009 4:31 pm

Re: Monit Service Manager problem

Postby bigfoot65 » Fri Oct 12, 2018 10:35 am

Ah, yes and you did not uninstall apps as recommended in the instructions.

That's likely been the cause of many of your issues.

Always best if doing an upgrade to have no apps installed. The new Amahi version often has updated app versions to align with the new OS. Some apps from the previous version break during the upgrade obviously.

No worries, just wanted to understand.

I presume we can mark this as resolved.
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 3 guests