Amahitunes No Longer Streaming Music

hypertense
Posts: 51
Joined: Thu Jan 27, 2011 3:53 pm

Amahitunes No Longer Streaming Music

Postby hypertense » Thu Oct 13, 2011 3:23 am

Until recently I was using Amahitunes to stream music to iTunes for my daughter and all the songs showed up properly on her laptop. Recently, however, it started showing only about 200 of the songs, so I tried to reinstall Amahitunes and paid the new fee for it.

Things got worse. The number of tracks listed now stands at precisely nil. I've tried reinstalling many times and played around with the configuration. I have noticed from the logs that on 07 October 4458 songs were scanned but on 12 October this fell to 250. I did do a yum update some time in this period, but should this have affected Amahitunes?

Any help gratefully received as my daughter is making my life hell.

hypertense

User avatar
bigfoot65
Project Manager
Posts: 11397
Joined: Mon May 25, 2009 4:31 pm

Re: Amahitunes No Longer Streaming Music

Postby bigfoot65 » Thu Oct 13, 2011 5:53 am

Have you checked the app install log to see if there were any errors. Also,are you using Greyhole? If so, you might need the mount_local_shares script running.

Not sure if this will help, but thought it was worth mentioning.
ßîgƒσστ65
Applications Manager

hypertense
Posts: 51
Joined: Thu Jan 27, 2011 3:53 pm

Re: Amahitunes No Longer Streaming Music

Postby hypertense » Thu Oct 13, 2011 7:35 am

Thanks for your suggestions bigfoot
Have you checked the app install log to see if there were any errors. Also,are you using Greyhole? If so, you might need the mount_local_shares script running.
There are no errors showing on the install log and I've tried your suggestion re: mount_local_shares script but still the same.

hypertense

User avatar
bigfoot65
Project Manager
Posts: 11397
Joined: Mon May 25, 2009 4:31 pm

Re: Amahitunes No Longer Streaming Music

Postby bigfoot65 » Thu Oct 13, 2011 1:58 pm

Hello,

Sorry the suggestions did not help. Did you check the share directory from command line to ensure the music is not symlinked? If it is, could be a potential problem with how Amahi Tunes handles them.

The mount_local_shares may not resolve that issue either.
ßîgƒσστ65
Applications Manager

hypertense
Posts: 51
Joined: Thu Jan 27, 2011 3:53 pm

Re: Amahitunes No Longer Streaming Music

Postby hypertense » Fri Oct 14, 2011 2:04 am

Hello Bigfoot

Thanks for the pointer re: symlinks. As I am using a Greyhole share for my music folder it is all symlinks. This hadn't caused a problem before, but it obviously is now as if I change the music folder for Amahitunes to a drive that is not pooled it picks up the music.

Incidentally this also solves the problem that some people have of Amahitunes not showing the songs in the browser window. I never could see them but didn't care so long as the music was picked up in iTunes. Thinking about it, as I added new songs they would show up for a second or two before disappearing as (I presume) Greyhole transferred the files to the pool.

Now that I see the problem, is there a solution? I don't want my music to be taken off the pooled storage because that was one of the attractions of Amahi to me. Obviously something has changed recently as Amahitunes worked previously (except for the songs counter). Apart from the yum updates I carried out, the only other alteration to the system that I can think of is that I created a new music folder and copied all my music over because there were major issues that were causing Squeezeserver not to pick up all the music.

Any suggestions from anyone gratefully received.

hypertense

User avatar
bigfoot65
Project Manager
Posts: 11397
Joined: Mon May 25, 2009 4:31 pm

Re: Amahitunes No Longer Streaming Music

Postby bigfoot65 » Fri Oct 14, 2011 4:56 am

One thing that might help with greyhole is pointing Amahi Tunes to the samba mount for the Music share. I saw a post recently that indicated doing that for another app. I think that is why Amahi Tunes is not seeing the music as its seeing the folder as a directory and not a samba share.

There was some mention of stopping the mount_local_shares script, removing the /mnt/samba/* dir, then restarting the script. If you look in that directory for the music share and don't see all your files, that could be the issue.

Just a thought.
ßîgƒσστ65
Applications Manager

hypertense
Posts: 51
Joined: Thu Jan 27, 2011 3:53 pm

Re: Amahitunes No Longer Streaming Music

Postby hypertense » Fri Oct 14, 2011 5:50 am

Here's what I've done.

I've pointed Amahitunes directly to /var/hda/files/drives/drive11/gh/Music/MP4/ which is one of the Greyhole copies of the data. I assume that Amahitunes only reads data so it will not mess up Greyhole by writing data directly. I presume if I run low on space on this disk some of the songs will not show as Greyhole will put them on another disk.

Not ideal, but it works while I find the time to try other solutions.

If this may cause problems for the system please let me know before I break it!

hypertense

User avatar
bigfoot65
Project Manager
Posts: 11397
Joined: Mon May 25, 2009 4:31 pm

Re: Amahitunes No Longer Streaming Music

Postby bigfoot65 » Fri Oct 14, 2011 6:12 am

That should work. Ideally it would be better if you could the the samba share working correctly via the mount_local_shares.

I have noticed that the script does have issues at times. I had removed a share and directory, yet it was still mounted and existed in /mnt/samba. I had to manually remove it and then rebooted the HDA to clear things out.

Many of these streaming apps precluded greyhole, so I am guessing the symlinks are the issues. Not sure if we can figure out a better way to make them work together better.
ßîgƒσστ65
Applications Manager

hypertense
Posts: 51
Joined: Thu Jan 27, 2011 3:53 pm

Re: Amahitunes No Longer Streaming Music

Postby hypertense » Fri Oct 14, 2011 6:45 am

I've just had a few minutes spare so played around with pointing Amahitunes to the samba mount (i.e. /mnt/samba/Music/MP4). Many attempts at restarting the Amahitunes server failed until I pointed it to /mnt/samba, at which point it restarted and found all my music.

It still won't work if I try and point to the samba subdirectory /music but as I don't have music anywhere else I can live with that. If I ever split the music directory (for example have "my music" and "the family's crap music") I'll worry about it then.

Thanks for your help bigfoot.

hypertense

User avatar
bigfoot65
Project Manager
Posts: 11397
Joined: Mon May 25, 2009 4:31 pm

Re: Amahitunes No Longer Streaming Music

Postby bigfoot65 » Fri Oct 14, 2011 1:18 pm

Awesome, glad its working for you. Would it be possible for you to add the steps to the wiki? The page for Amahi Tunes is located here:

http://wiki.amahi.org/index.php/AmahiTunes

It would be greatly appreciated and I am sure it will help others.
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 1 guest