Page 1 of 1

SOLVED: SABnzbd Connection failed!

Posted: Mon Feb 20, 2017 9:58 am
by spaceman
My status is returning:

Code: Select all

Local IPv4 address Public IPv4 address Connection failed! IPv6 address None Nameserver/DNS Lookup Connection failed!
This is entirely my own fault and I can rollback if the problem is not resolvable.

I've provisioned two HDAs in network @ and the other at I turned DHCP/DNS serving off on ...10 which is more of a NAS server really: it has webmin and miniDNLA only installed. ...100 has SABnzbd, CouchPotato and Sickrage deployed and it serves DHCP. This setup worked fine (so why mess with it?!)

I had delay issues with web browsing so I switched off the DHCP/DNS services on ...100 and turned then on for ...10. Web browsing performance seems smoother so I like to keep DNS resolving on ...10 if possible.

I manually created DNS Aliases on ...10 for the applications installed on ...100. Wordpress, for example, works fine and my blog resolves from inside and outside the LAN. I can access all apps from the LAN including SABnzbd.

The only issue in my non-standard set up is SABnzbd connectivity. I'm running iptables (on both servers) and this is the entry I added to ...10:

Code: Select all

## Open access to SABnzbdPlus server -A INPUT -m state --state NEW -p tcp --dport 563 -j ACCEPT -A INPUT -m state --state NEW -p udp --dport 563 -j ACCEPT
563 is the port I access my news service on. I'm not sure that this is a useful entry, but if I opened WAN access to 25915 I'd be able to access SABnzbd from outside the LAN which is not what I want. I have port forwarding setup on my router for torrents and suspect I need the same for SAB... but which port?

I realise this is not a normal Amahi setup, so the support I can expect is very limited. However, some generic pointers should get this resolved for me I hope.

Re: SABnzbd Connection failed!

Posted: Mon Feb 20, 2017 12:59 pm
by bigfoot65
You might check out app ports in the wiki.

Re: SABnzbd Connection failed!

Posted: Mon Feb 20, 2017 3:31 pm
by spaceman
Thank you bigfoot65, but the only information this page contains that is pertinent is the web interface port of SABnzbd:

Code: Select all

SABnzbd Plus 25915
I already tried poking a hole in the Firewall for this port:

Code: Select all

-A INPUT -m state --state NEW -p tcp --dport 25915 -j ACCEPT -A INPUT -m state --state NEW -p udp --dport 25915 -j ACCEPT
...and it hasn't made any difference. :(
Incidentally I have two firewalls, one on each server. is this sensible or should I only enable one on the DHCP server? If I use both which (or both) should have port 25915 open? Also do I need to forward port 25915 to - the Amahi server running SABnzbd? :?

Thank you for you advice.

Re: SABnzbd Connection failed!

Posted: Tue Feb 21, 2017 6:50 am
by spaceman
I'm going to mark this resolved. As I'm not 100% where the problem lies and it's probably beyond the scope of the Amahi forum, thank you for taking the time and offering some input Bigfoot.

I flushes both firewalls and built my rules-sets up slowly. I still couldn't connect to my news service, I pinged it and it was resolving so I took the IP address and entered that in SABnzbd's Host Name voilĂ .

I won't pursue this thread when my ignorance of iptables is the root cause of my difficulties. I will experiment and learn (and try to update the wiki with all the app ports). :mrgreen:

Re: SABnzbd Connection failed!

Posted: Tue Feb 21, 2017 7:13 am
by bigfoot65
No worries.

Happy to assist and glad you got it sorted out.

Running two HDAs on the same network often does not work for most users. Sounds like you have it working. Is there anything you can add to the wiki regarding the setup/configuration?

How to use two HDAs on the same network