SOLVED: Failing to start

dekthro
Posts: 21
Joined: Fri Mar 21, 2014 2:10 pm

SOLVED: Failing to start

Postby dekthro » Fri Mar 21, 2014 4:23 pm

Sab is failing to start, and appears to just time out.

from 'systemctl status sabnzbd.service'

Code: Select all

sabnzbd.service - SABnzbd Plus server Loaded: loaded (/usr/lib/systemd/system/sabnzbd.service; enabled) Active: failed (Result: timeout) since Fri 2014-03-21 16:17:56 PDT; 14s ago Process: 23124 ExecStart=/var/hda/web-apps/sabnzbdplus/html/SABnzbd.py --browser 0 --daemon --pid /var/run/sabnzbd/ --config-file /var/hda/web-apps/sabnzbdplus/html/sabnzbd.ini (code=exited, status=0/SUCCESS) Process: 23122 ExecStartPre=/usr/bin/chown -R apache:users /var/run/sabnzbd/ (code=exited, status=0/SUCCESS) Process: 23119 ExecStartPre=/usr/bin/mkdir -p /var/run/sabnzbd/ (code=exited, status=0/SUCCESS) Mar 21 16:16:26 localhost.localdomain systemd[1]: PID file /var/run/sabnzbd/sabnzbd-25915.pid not readable (...art. Mar 21 16:17:56 localhost.localdomain systemd[1]: sabnzbd.service operation timed out. Terminating. Mar 21 16:17:56 localhost.localdomain systemd[1]: Failed to start SABnzbd Plus server. Mar 21 16:17:56 localhost.localdomain systemd[1]: Unit sabnzbd.service entered failed state.
I've checked /var/run/sabnzbd/ for the referenced PID file, and the only one there is a

Code: Select all

-rw------- 1 apache users 6 Mar 21 16:31 sabnzbd-8080.pid
I've tried uninstalling and reinstalling this as well.

User avatar
bigfoot65
Project Manager
Posts: 11397
Joined: Mon May 25, 2009 4:31 pm

Re: Failing to start

Postby bigfoot65 » Fri Mar 21, 2014 5:59 pm

Did you change the port? It defaults to 25915.

The PID file you listed is 8080. If you change the port, it must be manually changed in the service as well.

I have tested the app and works with no issues on my test machine.
ßîgƒσστ65
Applications Manager

dekthro
Posts: 21
Joined: Fri Mar 21, 2014 2:10 pm

Re: Failing to start

Postby dekthro » Fri Mar 21, 2014 6:07 pm

As far as I know I hadn't changed anything, and that is what I had assumed as well. I checked the sabnzbd.ini file and I didn't even see it listed at all.

EDIT: Located, updated, and it is directing me back to http://localhost:25915/wizard/ when trying to access http://sabnzbdplus/
Last edited by dekthro on Fri Mar 21, 2014 6:13 pm, edited 1 time in total.

User avatar
bigfoot65
Project Manager
Posts: 11397
Joined: Mon May 25, 2009 4:31 pm

Re: Failing to start

Postby bigfoot65 » Fri Mar 21, 2014 6:12 pm

It is in the .ini file, should read:
port = 25915.
Uninstall, then before you reinstall remove the .ini file from /var/hda/files/newsgroups share. That is where it's backed up on uninstall for upgrade purposes.
ßîgƒσστ65
Applications Manager

dekthro
Posts: 21
Joined: Fri Mar 21, 2014 2:10 pm

Re: Failing to start

Postby dekthro » Fri Mar 21, 2014 6:15 pm

Ahh that was what was messing things up. Something must have gone wrong in the settings file. Everything is peachy now, thank you, bigfoot65!

User avatar
bigfoot65
Project Manager
Posts: 11397
Joined: Mon May 25, 2009 4:31 pm

Re: Failing to start

Postby bigfoot65 » Fri Mar 21, 2014 6:21 pm

Awesome. Sorry for the inconvenience.

One day we will have a way to allow apps to selectively use backup files vs doing it automatically.
ßîgƒσστ65
Applications Manager

User avatar
hemington1
Posts: 151
Joined: Mon Nov 26, 2012 6:38 pm
Location: Perth Western Australia

Re: SOLVED: Failing to start

Postby hemington1 » Mon Aug 18, 2014 8:39 pm

I should have looked here first................
My SAB stopped working and I thought the port was the problem, so I changed it to 8080 and now I can't get the server to start. I'll do the recommended fix shown here tonight...............
Amahi 11
Intel i7 quad core 2.8GHz
1 GiB Geforce graphics
16 GiB RAM
Sagemcom Gateway 3864 modem/router

User avatar
hemington1
Posts: 151
Joined: Mon Nov 26, 2012 6:38 pm
Location: Perth Western Australia

Re: SOLVED: Failing to start

Postby hemington1 » Tue Aug 19, 2014 4:57 am

No need to delete ini file, just edit and change port. Working now.
Amahi 11
Intel i7 quad core 2.8GHz
1 GiB Geforce graphics
16 GiB RAM
Sagemcom Gateway 3864 modem/router

jdwoodalljrawoodall
Posts: 3
Joined: Tue Feb 10, 2015 3:54 pm

Re: SOLVED: Failing to start

Postby jdwoodalljrawoodall » Tue Feb 10, 2015 3:58 pm

I am having trouble accessing the config file. When I first installed sab it worked fine. I know I set it up wrong but I am unable to access file to remove my settings via putty I am running the headless server

User avatar
bigfoot65
Project Manager
Posts: 11397
Joined: Mon May 25, 2009 4:31 pm

Re: SOLVED: Failing to start

Postby bigfoot65 » Tue Feb 10, 2015 4:07 pm

This is a closed thread. In future, please start a new one.

You can manually edit the file. It's located in /var/hda/files/sabnzbdplus/html directory. It's called sabnzbd.ini.

The other alternative is to uninstall, then remove the backup configuration file from /var/hda/files/newsgroups, then reinstall.
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 1 guest