A little help on setting up for everyone

shu
Posts: 15
Joined: Mon Feb 09, 2009 11:18 am

A little help on setting up for everyone

Postby shu » Thu Mar 12, 2009 10:14 am

Ok guys,

Everything works pretty much out of the box guys. But there are some configuration steps that need to be done.

You might have some issues with it not unraring. The reason for this is unrar is not installed by default you will need to install unrar for it to work properly.

Anther issues is user's permissions. Since sabnzbd runs as apache you will need to edit the sabnzbd to run as a differnt user that has access to shared dir.

The config file is in. /etc/init.d/sabnzbd
vi sabnzbd.confg
edit the line here:

Code: Select all

echo -n $"Starting $prog: " daemon --user YOUR_USER_NAME $exec retval=$? echo [ $retval -eq 0 ] && touch $lockfile return $retval
Replace apache in YOUR_USER_NAME by your user name.

By doing this is will give the correct permissions levels for the sabnzbd to access your folder shares.
You also need to set sabnzbd with 0777 permissions in the folders tab of sabnzbd

If I missed anything please post here I will try to help out as best I can or you can catch me in the IRC chat.

Turkannodland
Posts: 19
Joined: Thu Feb 26, 2009 3:36 pm

Re: A little help on setting up for everyone

Postby Turkannodland » Sun Mar 15, 2009 3:05 pm

I installed this application from the dashboard setup. It seemed to install fine and I am able to start tthe application. But it don't seem to work. So I searched this forum and I tried to implement the sabnzbd.conf recommended. But I can't find the file in /etc/init.d.
Maybe the application has not been installed properly or missing some other components it depends on. I checked the Service configuration and it shows sabnzbd is installed and enabeled but it says also "This service is dead".

Is there a way to fix this?

ajose01
Posts: 6
Joined: Thu Mar 05, 2009 3:41 pm

Re: A little help on setting up for everyone

Postby ajose01 » Thu Mar 26, 2009 5:40 pm

Thanks for the work around. The problem I ran into is the following.

After changing the username, when trying to restart sabnzbd i get the following error: I refuse to fork without a log directory!

If I change the username back to apache, error goes away and everything plays nice. Any ideas on how to fix? Thanks!

User avatar
moredruid
Expert
Posts: 791
Joined: Tue Jan 20, 2009 1:33 am
Location: Netherlands
Contact:

Re: A little help on setting up for everyone

Postby moredruid » Fri Mar 27, 2009 12:24 am

search for the log directory (it's probably the httpd.log files it's complaining about) in the config file.
if you find it you can do 2 things:
1 - create a directory with the proper permissions and use that as the logging directory
2 - change the permissions of the default directory

of course #1 is more elegant, and actually the way it should be set up :)
perhaps this is something for the API documentation?
echo '16i[q]sa[ln0=aln100%Pln100/snlbx]sbA0D2173656C7572206968616D41snlbxq' | dc
Galileo - HP Proliant ML110 G6 quad core Xeon 2.4GHz, 4GB RAM, 2x750GB RAID1 + 2x1TB RAID1 HDD

shu
Posts: 15
Joined: Mon Feb 09, 2009 11:18 am

Re: A little help on setting up for everyone

Postby shu » Fri Mar 27, 2009 6:58 am

This means your user does not have the correct permissions to write to the log dir. What i did is change the user to root and you dont have to worry about permissions. Im trying to find out where the log dir is.

Who is online

Users browsing this forum: No registered users and 3 guests