SOLVED: HDA Update last night, re: plex

cdcrawford
Posts: 13
Joined: Fri Dec 14, 2012 7:29 am

SOLVED: HDA Update last night, re: plex

Postby cdcrawford » Thu Feb 13, 2014 7:38 am

So, my HDA updated last night, and it replaced my release from Plex with the amahi-plex-0.1.3-1.x86_64 package from the Amahi repo. Now, my PMS won't start today.

Code: Select all

starting at Thu Feb 13 02:01:01 AST 2014 first, sleep 59 seconds to avoid contentions hda update attempt #1 @ Thu Feb 13 02:02:00 AST 2014 Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile * fedora: fedora.mirror.nexicom.net * rpmfusion-free: mirror.nexcess.net * rpmfusion-free-updates: mirror.nexcess.net * rpmfusion-nonfree: mirror.nexcess.net * rpmfusion-nonfree-updates: mirror.nexcess.net * updates: fedora.mirror.nexicom.net Package hda-greyhole-0.9.39-5.x86_64 already installed and latest version Package hda-ctl-5.1.4-1.x86_64 already installed and latest version Package hda-platform-7.1.1-1.x86_64 already installed and latest version Package hda-release-6.9.0-1.noarch already installed and latest version Nothing to do Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile * fedora: fedora.mirror.nexicom.net * rpmfusion-free: mirror.nexcess.net * rpmfusion-free-updates: mirror.nexcess.net * rpmfusion-nonfree: mirror.nexcess.net * rpmfusion-nonfree-updates: mirror.nexcess.net * updates: fedora.mirror.nexicom.net Resolving Dependencies --> Running transaction check ---> Package amahi-plex.x86_64 0:0.1.3-1 will be obsoleting ---> Package plexmediaserver.x86_64 0:0.9.8.14.263-139ddbc will be obsoleted --> Finished Dependency Resolution Dependencies Resolved ================================================================================ Package Arch Version Repository Size ================================================================================ Installing: amahi-plex x86_64 0.1.3-1 amahi 56 M replacing plexmediaserver.x86_64 0.9.8.14.263-139ddbc Transaction Summary ================================================================================ Install 1 Package Total download size: 56 M Downloading packages: Running transaction check Running transaction test Transaction test succeeded Running transaction Installing : amahi-plex-0.1.3-1.x86_64 1/2 Redirecting to /bin/systemctl stop plex.service Failed to issue method call: Unit plex.service not loaded. Erasing : plexmediaserver-0.9.8.14.263-139ddbc.x86_64 2/2 Verifying : amahi-plex-0.1.3-1.x86_64 1/2 Verifying : plexmediaserver-0.9.8.14.263-139ddbc.x86_64 2/2 Installed: amahi-plex.x86_64 0:0.1.3-1 Replaced: plexmediaserver.x86_64 0:0.9.8.14.263-139ddbc Complete!
So far, what I've gather is that it changed my permissions on my HDA for /var/lib/plexmediaserver/ from plex:users to apache:users. Restarted my application, and now I am not able to access my from anywhere in my house. Good times.

Anyone have an idea on how to fix this?

cdcrawford
Posts: 13
Joined: Fri Dec 14, 2012 7:29 am

Re: HDA Update last night, re: plex

Postby cdcrawford » Thu Feb 13, 2014 7:49 am

Update:
Found the service that would start plex. It's amahi-plex.service. I'm trying now to figure out how to start it without errors. It won't start on boot now. But, that's correctable.

I'll update when I know more.

Hopefully, my database is intact.

cdcrawford
Posts: 13
Joined: Fri Dec 14, 2012 7:29 am

Re: HDA Update last night, re: plex

Postby cdcrawford » Thu Feb 13, 2014 8:20 am

Database is intact.

I ran the following to correct the problem:
Changed the users of my database, from plex:users to apache:users. It was half done. Most people will NOT have to do this.

Code: Select all

sudo chown apache:users /var/lib/plexmediaserver/
Allowed the amahi-plex.service to start on boot:

Code: Select all

sudo systemctl enable amahi-plex
Started the service:

Code: Select all

sudo systemctl start amahi-plex
Get the status of the service.

Code: Select all

sudo systemctl status amahi-plex amahi-plex.service - Plex Media Server for Amahi Loaded: loaded (/usr/lib/systemd/system/amahi-plex.service; enabled) Active: active (running) since Thu 2014-02-13 11:13:20 AST; 1min 43s ago Process: 787 ExecStart=/usr/bin/amahi-plex (code=exited, status=0/SUCCESS) Main PID: 800 (runuser) CGroup: name=systemd:/system/amahi-plex.service ├─ 800 runuser -u apache -g users /usr/lib64/plexmediaserver/Plex Media Server ├─ 840 /usr/lib64/plexmediaserver/Plex Media Server ├─1512 Plex Plug-in [com.plexapp.system] /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-ins/Framework.bundle/Contents/Resourc... └─1805 /usr/lib64/plexmediaserver/Plex DLNA Server
All is good in the hood!

BigMcLargeHuge
Posts: 13
Joined: Sun May 02, 2010 8:15 pm

Re: HDA Update last night, re: plex

Postby BigMcLargeHuge » Thu Feb 13, 2014 9:25 am

Thanks for the information cdcrawford, that worked for me. My question is why did Amahi replace the release from Plex, when I didn't buy the PMS app from Amahi? Should that behavior even be allowed?

User avatar
bigfoot65
Project Manager
Posts: 11419
Joined: Mon May 25, 2009 4:31 pm

Re: HDA Update last night, re: plex

Postby bigfoot65 » Thu Feb 13, 2014 3:47 pm

Thanks for the report. I have filed a bug so we can fix the RPM.
https://bugs.amahi.org/issues/1302#change-3548

When we release the Plex Media Server app, it will be using amahi-plex so all the issues with dependencies and DLNA will be resolved.

Recommend that users stick with amahi-plex vs the plex RPM or things will break again.
ßîgƒσστ65
Applications Manager

zombu2
Posts: 7
Joined: Wed Aug 24, 2011 8:34 am

Re: HDA Update last night, re: plex

Postby zombu2 » Thu Feb 13, 2014 4:20 pm

This is stating a real problem since now i cannot install the newest version of plex which is way far ahead of what is supplied by amahi .

you used to be able to just load the rpm and update it but now it is obsoleted by the amahi supplied version

not good

User avatar
bigfoot65
Project Manager
Posts: 11419
Joined: Mon May 25, 2009 4:31 pm

Re: HDA Update last night, re: plex

Postby bigfoot65 » Thu Feb 13, 2014 4:47 pm

Please add this concern to the bug I mentioned in the previous post.

I presume you can uninstall the Amahi app and install it manually, correct? Of course you may need to exclude amahi-plex in the yum config file.
ßîgƒσστ65
Applications Manager

irishxlink
Posts: 43
Joined: Tue Dec 22, 2009 8:50 am

Re: HDA Update last night, re: plex

Postby irishxlink » Mon Feb 17, 2014 12:17 pm

This happened to me as well today. My plexpass version is being overruled "due to obsoletes from installed amahi-plex." How would i exclude amahi-plex in the yum config?

User avatar
bigfoot65
Project Manager
Posts: 11419
Joined: Mon May 25, 2009 4:31 pm

Re: HDA Update last night, re: plex

Postby bigfoot65 » Mon Feb 17, 2014 12:29 pm

Edit /etc/yum.conf and add the following at the bottom :

Code: Select all

exclude=amahi-plex
When you run yum update, it should now ignore it.
ßîgƒσστ65
Applications Manager

irishxlink
Posts: 43
Joined: Tue Dec 22, 2009 8:50 am

Re: HDA Update last night, re: plex

Postby irishxlink » Mon Feb 17, 2014 12:31 pm

Thanks Bigfoot

Who is online

Users browsing this forum: No registered users and 2 guests