Amahi media server not showing one of two video folders

BlackSmith
Posts: 14
Joined: Thu Sep 20, 2012 6:05 pm

Amahi media server not showing one of two video folders

Postby BlackSmith » Sun Sep 23, 2012 10:05 am

With the help of BigFoot65 (thanks again!), I have my Amahi media server running with the media files on greyhole shares. I have the following shares set up in minidlna.conf:

Code: Select all

media_dir=A,/mnt/2TBSmallPart/landing-zones/music-LZ media_dir=V,/mnt/2TBSmallPart/landing-zones/films-LZ media_dir=V,/mnt/2TBSmallPart/landing-zones/videos-LZ media_dir=P,/mnt/2TBSmallPart/landing-zones/photos-LZ
with permissions set to:

Code: Select all

drwxrwxr-x 5 xyz users 4096 Sep 14 14:34 films-LZ/ drwxrwxrwx 17 xyz users 4096 Aug 27 21:05 library-LZ/ drwxrwxrwx 607 xyz users 20480 Sep 10 01:25 music-LZ/ drwxrwxrwx 21 xyz users 4096 Sep 10 17:56 photos-LZ/ drwxrwxrwx 13 xyz users 4096 Aug 28 19:12 videos-LZ/
where xyz is the first Amahi user. When I access the media server from a DLNA client, I see the files in the films share but not those in the videos share. In the /var/log/minidlna.log file I see errors that look like this:

Code: Select all

[2012/09/23 10:33:12] inotify.c:89: error: inotify_add_watch(/mnt/2TBSmallPart/landing-zones/music-LZ/Zac Brown Band [2008] The Foundation [No space left on device]
for each folder that is in the shares. There is ample space on each share, as shown here:

Code: Select all

Filesystem Size Used Avail Use% Mounted on /dev/sdb1 459G 175G 261G 41% /mnt/500GBDrive /dev/sdd1 37G 4.4G 31G 13% /mnt/40GBDrive /dev/sdc1 187G 120G 58G 68% /mnt/180GBDrive /dev/sda1 1.6T 154G 1.4T 11% /mnt/2TBBigPartt /dev/sda2 193G 25G 159G 14% /mnt/2TBSmallPart
The landing zones are located on 2TBSmallPart and the remainder of those listed are part of the storage pool. What's going on? I don't understand why minidlna is showing no space on those drives when it appears that there is space available. I also don't understand why the DLNA client is not listing all of the files in the "videos" share but does show the videos in the "films" share. The music and photos shares are listed on the DLNA client and appear to be read correctly.

Any thoughts? Thanks for the great community support.

User avatar
cpg
Administrator
Posts: 2605
Joined: Wed Dec 03, 2008 7:40 am
Contact:

Re: Amahi media server not showing one of two video folders

Postby cpg » Sun Sep 23, 2012 2:12 pm

Why are you dealing with landing zones?

If these are greyhole landing zones, you should be expecting to see or touch the files there as they are basically in flight.

There clearly is some partition somewhere out of space:

Code: Select all

No space left on device
My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 8GB RAM, 1TBx2+3TBx1

BlackSmith
Posts: 14
Joined: Thu Sep 20, 2012 6:05 pm

Re: Amahi media server not showing one of two video folders

Postby BlackSmith » Sun Sep 23, 2012 2:19 pm

I appreciate you taking the time to help. I hear you about a partition being out of space, but there are NO partitions out of space on my server, as seen here:

Code: Select all

xyz@ForgeServer:~$ df -h Filesystem Size Used Avail Use% Mounted on /dev/sda6 9.7G 3.1G 6.1G 34% / udev 236M 12K 236M 1% /dev tmpfs 98M 1.4M 96M 2% /run none 5.0M 0 5.0M 0% /run/lock none 243M 0 243M 0% /run/shm /dev/sdb1 459G 175G 261G 41% /mnt/500GBDrive /dev/sdd1 37G 4.4G 31G 13% /mnt/40GBDrive /dev/sda5 20G 173M 19G 1% /home /dev/sdc1 187G 120G 58G 68% /mnt/180GBDrive /dev/sda1 1.6T 154G 1.4T 11% /mnt/2TBBigPart /dev/sda2 193G 25G 159G 14% /mnt/2TBSmallPart //127.0.0.1/films 2.3T 568G 1.7T 25% /mnt/samba/films //127.0.0.1/library 2.3T 568G 1.7T 25% /mnt/samba/library //127.0.0.1/music 2.3T 568G 1.7T 25% /mnt/samba/music //127.0.0.1/photos 2.3T 568G 1.7T 25% /mnt/samba/photos //127.0.0.1/videos 2.3T 568G 1.7T 25% /mnt/samba/videos xyz@ForgeServer:~$
That's all of the partitions and nothing is utilized more than 68%.

In response to your other point, BigFoot helped me out yesterday and indicated that MiniDLNA needs to be pointed to the landing zones in order to function correctly. I had MiniDLNA pointed at the locally mounted samba shares (mounted using the greyhole mount_shares_locally script) and the DLNA server wasn't showing any of my flies to the client. I changed minidlna.conf to point to the landing zones and now the content of three of the four shares appear on the DLNA client. Hence my confusion. I even changed the ownership on EVERYTHING to xyz:users as I read in other posts that miniDLNA requires that all folders and files be owned by FirstAmahiUser:users. Still no luck. What am I missing?

Who is online

Users browsing this forum: No registered users and 2 guests