DHCP configuration question

modem7
Posts: 215
Joined: Tue Mar 20, 2012 6:00 pm

Re: DHCP configuration question

Postby modem7 » Tue May 21, 2019 3:31 am

I did some playing around, and pi-hole can be installed along side Amahi. It does take some work, but since they are both dnsmasq based, they work alongside together without a whole lot of effort. I plan on documenting how I did it in a Wiki entry, once I work out a few more details.
Heya,

I'm looking to do the same, are you able to give a brief top level overview on the steps you did?

Thanks!

User avatar
bigfoot65
Project Manager
Posts: 11465
Joined: Mon May 25, 2009 4:31 pm

Re: DHCP configuration question

Postby bigfoot65 » Wed May 22, 2019 5:10 pm

Have you checked out ad blocking guidance in the wiki?

I provides a similar capability as pi-Hole.
ßîgƒσστ65
Applications Manager

modem7
Posts: 215
Joined: Tue Mar 20, 2012 6:00 pm

Re: DHCP configuration question

Postby modem7 » Wed May 22, 2019 5:46 pm

Have yo checked out ad blocking guidance in the wiki?

I provides a similar capability as pi-Hole.
I wasn't even aware!

I'll give it a look tomorrow, thank you!

tamorgen
Posts: 53
Joined: Wed Jul 17, 2013 1:48 pm

Re: DHCP configuration question

Postby tamorgen » Wed May 29, 2019 8:55 am

I did some playing around, and pi-hole can be installed along side Amahi. It does take some work, but since they are both dnsmasq based, they work alongside together without a whole lot of effort. I plan on documenting how I did it in a Wiki entry, once I work out a few more details.
Heya,

I'm looking to do the same, are you able to give a brief top level overview on the steps you did?

Thanks!
Modem7,
Sorry for not getting back with you sooner. I haven't been online much this past week with the holiday weekend and all. I've got it working, but I'm still trying to make some changes to make it better integrated with Amahi. Part of it is how my DHCP works for my WiFi clients from my Ubiquiti SGW, but that's a whole different ball of wax.

Essentially, I used the Pi-hole script, and let it do it's thing. You then have to make some changes. You need to change the port lighttpd uses to present the admin page to something other than port 80. The HDA console already uses port 80, so you need to change it to an unused port. There is a setting in the config file under /etc/lighttpd/lighttpd.conf that you need to change.

Code: Select all

server.port = 81
Once that's done, you'll need to get the service running. I have a thread over on Pi-hole's Discourse forum that shows how I went through to get the service running.

Once you have done this, you should have Pi-hole up and running. For my next trick, I'm trying to migrate from Lighttpd to the existing Apache instance on the Amahi box. Doing that, I should be able to use port 80 and not 81, since I'll just be running a different instance of the web server with a different prefix. Once that is migrated, which shouldn't be that hard, but I haven't spent an extraordinary time doing it, is to migrate the Pi-hole admin console to https.

I plan on documenting this process a bit more once everything is done, but I just haven't had a whole lot of time. The results have been worth it. Currently about 13% of my traffic is being blackholed by Pi-hole, most of which is ads.

modem7
Posts: 215
Joined: Tue Mar 20, 2012 6:00 pm

Re: DHCP configuration question

Postby modem7 » Sat Jun 01, 2019 5:15 pm

I did some playing around, and pi-hole can be installed along side Amahi. It does take some work, but since they are both dnsmasq based, they work alongside together without a whole lot of effort. I plan on documenting how I did it in a Wiki entry, once I work out a few more details.
Heya,

I'm looking to do the same, are you able to give a brief top level overview on the steps you did?

Thanks!
Modem7,
Sorry for not getting back with you sooner. I haven't been online much this past week with the holiday weekend and all. I've got it working, but I'm still trying to make some changes to make it better integrated with Amahi. Part of it is how my DHCP works for my WiFi clients from my Ubiquiti SGW, but that's a whole different ball of wax.

Essentially, I used the Pi-hole script, and let it do it's thing. You then have to make some changes. You need to change the port lighttpd uses to present the admin page to something other than port 80. The HDA console already uses port 80, so you need to change it to an unused port. There is a setting in the config file under /etc/lighttpd/lighttpd.conf that you need to change.

Code: Select all

server.port = 81
Once that's done, you'll need to get the service running. I have a thread over on Pi-hole's Discourse forum that shows how I went through to get the service running.

Once you have done this, you should have Pi-hole up and running. For my next trick, I'm trying to migrate from Lighttpd to the existing Apache instance on the Amahi box. Doing that, I should be able to use port 80 and not 81, since I'll just be running a different instance of the web server with a different prefix. Once that is migrated, which shouldn't be that hard, but I haven't spent an extraordinary time doing it, is to migrate the Pi-hole admin console to https.

I plan on documenting this process a bit more once everything is done, but I just haven't had a whole lot of time. The results have been worth it. Currently about 13% of my traffic is being blackholed by Pi-hole, most of which is ads.
Thanks for the heads up!

I've managed to get it working on the pi running alongside Nginx (disabled Lighthttpd), but the only thing that doesn't seem to work as intended is the upstream DNS part so that pihole queries the HDA if there's anything it doesn't understand.

Did you manage to get past this at all?

Who is online

Users browsing this forum: No registered users and 3 guests