Several Issues with WOL

sharmac
Posts: 12
Joined: Wed Jan 18, 2017 6:12 pm

Several Issues with WOL

Postby sharmac » Fri Jan 20, 2017 1:20 am

I setup Amahi 7 with Fedora 19 on an old computer. It's a 32 bit machine so I can only use Amahi 7. From my other laptop (Windows 7), I am able to access the HDA dashboard. My next goal is to get WOL to work and that is where I ran into several issues:

I installed the Wake-On-LAN Server app and am able to access http://wolserver/wol.php from my windows machine. It successfully shows that the machine running Amahi 7 is "awake" but when I click the Sleep button, I get the following error:
Command Failed: Failed connect to 192.168.1.10:7760; Connection refused

Is there some configuration I have to change to get wol to work? I updated the passphrase hash in config.php.
I am wondering if I need to change some configuration related to the port for wol packet? I couldn't find anything on Amahi wiki for WOL

Is it even possible to use Wake-On-LAN app to put Amahi/Fedora to sleep?

Is putting Amahi to sleep the same thing as putting Fedora to sleep?
I assumed it was the same thing so I manually put Fedora to sleep. Then I went back to Wake-On-Lan app to check if it will let me awaken Fedora/Amahi from my Windows machine. However, http://wolserver/wol.php didn't even load since it is hosted on that Fedora. So I couldn't even attempt the waking up part. I must have assumed something incorrectly here.

I would really appreciate if you can point out what I am doing wrong, or help me get wol working.
Running Amahi 10 on Fedora 25
with Samba and Amahi Anywhere servers

User avatar
bigfoot65
Project Manager
Posts: 11447
Joined: Mon May 25, 2009 4:31 pm

Re: Several Issues with WOL

Postby bigfoot65 » Sat Jan 21, 2017 9:06 am

Is there some configuration I have to change to get wol to work?
Recommend you check /var/log/amahi-app-installer.log for errors.
Is it even possible to use Wake-On-LAN app to put Amahi/Fedora to sleep?
Doubtful as then you would lose all connectivity to the HDA and possibly the network. Also the machines that you want to WOL have to have that enabled in the BIOS.
Is putting Amahi to sleep the same thing as putting Fedora to sleep?
Yes. Won't work with the app as mentioned above. Does not make sense to put the server to sleep if that controls your network.

I will try to help, but since Amahi 7 on Fedora 19 has been retired for a year or so there's not much we can do to assist. We don't have any machines setup with it and can only provide limited assistance.
ßîgƒσστ65
Applications Manager

sharmac
Posts: 12
Joined: Wed Jan 18, 2017 6:12 pm

Re: Several Issues with WOL

Postby sharmac » Sun Jan 22, 2017 5:52 am

Thanks for the reply bigfoot65!

I got WOL to work (somewhat) by following some manual steps. Documenting them here for others.
1. Set wake-on to "g" using

Code: Select all

ethtool -s em1 wol g
2. Followed instructions on this page to enable wakeup for my Ethernet card.
3. Downloaded this windows wol tool to send the wol command from a Windows 7 machine to Amahi server.

After the server resumed, it worked for a while but when the screen went blank, I couldn't bring it back as the keyboard and mouse became non-responsive (reproduced this a few times). At this point my windows machine couldn't reach any site either as DNS resolution stopped working. I thought even if Amahi is down, DNS would fall back on my router as I haven't disabled it on the router.

Also, #1 and #2 above have to be repeated after reboot as they get reset. I haven't yet figured out how to make those changes permanent.

I can live with repeating the steps above after every reboot (will script them soon) but the keyboard/mouse/DNS lookup issue still needs to be resolved. Something locks up the machine running Amahi.

bigfoot65, going back to my question regarding the php wolserver being on the same machine as Amahi, is it different in the latest version of Amahi? I installed the "Wake-On-LAN Server" app and it put the php server on same machine as Amahi. I am wondering if this works differently in the latest Amahi version.
Running Amahi 10 on Fedora 25
with Samba and Amahi Anywhere servers

sharmac
Posts: 12
Joined: Wed Jan 18, 2017 6:12 pm

Re: Several Issues with WOL

Postby sharmac » Sun Jan 22, 2017 7:15 am

Update:
I got the wake-on=g setting to stick after rebooting. Here is what I did:

Followed instructions on this page to get the idea on how to solve the issue. The example on that page was for Ubuntu. I followed the answer here to make a fedora specific solution.

My wakeonlanconfig looks like this:

Code: Select all

#!/bin/bash # chkconfig: 2345 20 80 . /etc/init.d/functions ethtool -s em1 wol g exit 0
After rebooting the machine, wake-on=g was still set! Everything seems set on the machine hosting Amahi. Now, I wish I can get the Amahi "Wake on Lan Server" app to work.
Running Amahi 10 on Fedora 25
with Samba and Amahi Anywhere servers

User avatar
bigfoot65
Project Manager
Posts: 11447
Joined: Mon May 25, 2009 4:31 pm

Re: Several Issues with WOL

Postby bigfoot65 » Sun Jan 22, 2017 10:00 am

Good to hear you made progress.

Sorry but we cannot help much with the app since it's an old Amahi version. We have no way to replicate or test the app.

Hopefully you can sort it out. Would be interested to hear if you do. Maybe this is something we can capture in the wiki too.
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 3 guests