Amahi DLNA and Xbox 360 video problems

New to Amahi or Linux? Have a (what you think) is a simple question? Ask it here.
astx813
Posts: 3
Joined: Tue Aug 31, 2010 8:59 am

Amahi DLNA and Xbox 360 video problems

Postby astx813 » Tue Aug 31, 2010 9:41 am

I'm digging Amahi, it covers almost every detail I liked about WHS, with the added bonus of NOT being Windows! But I am having a problem with the most imprtant feature I set it up for: streaming video to my XBox 360. I have a fresh Amahi install (just did it last night) with DLNA and both RPM Fusion packages, music and movies are stored in the appropriate locations and show up on the Xbox. Music streams just fine, but none of the videos will play. The Xbox tries to buffer and then reports an error. I don't remember the exact error code (I'm at work now), but I'll come back and post in a followup. The thing is, I know my Xbox can play these movies! Before I installed Amahi, this server was running WHS and it was able to serve up the videos fine. I've also played them directly from a thumbdrive attached to the Xbox and from a uShare-enabled NAS device. Has anyone else run into this?

Extra details:
I've also installed Ajaxterm, Webmin, phpSysInfo, Ampache, and AmahiTunes. Wired networking for the Xbox & the HDA, plugged into a 10/100 router. The server is a Via C7 1GHz CPU w/ 1 gig of ram. I've got Fedora defaulting to runlevel 3 since this isn't a powerful box, and it's headless anyway. I haven't tried uShare yet, but I wasn't a fan of it on my linksys slug.

User avatar
cpg
Administrator
Posts: 2469
Joined: Wed Dec 03, 2008 7:40 am
Contact:

Re: Amahi DLNA and Xbox 360 video problems

Postby cpg » Tue Aug 31, 2010 12:30 pm

What format are them videos?

My xbox complains about xvid and cannot play mkv files. Even after updating some plugins and whatnot.

There is a new version in testing (see one of the recent postings I did a few hours ago), that has better support for Microsoft devices (in some unspecified way).

Personally, I have given up on the Xbox. They just do not want to play nice with all the formats out there.
My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 8GB RAM, 1TBx2+3TBx1

astx813
Posts: 3
Joined: Tue Aug 31, 2010 8:59 am

Re: Amahi DLNA and Xbox 360 video problems

Postby astx813 » Tue Aug 31, 2010 8:55 pm

OK, got back home and the error code is 69-C00D36B2.

Full text: "Can't play this content because it may not be supported. For more info, go to http://www.xbox.com/support. Status code: 69-C00D36B2

Like I said, these exact same files (most are DivX, I believe) played successfully with uShare before and off thumbdrives. I'm going to install uShare on this Amahi box and see if that works. If so, then there's got to be some way tog et the Xbox and DLNA playing nice. Well, I hope so, at least.

Edit: Yep, uShare works. Kinda. For some reason, it was trying to serve up the folder /var/hda/apps/ushare/files. Which the installer failed to create properly, but that's for another day (it's there, but it's corrupt and can't be removed). I changed the conf file to point to the /var/hda/files and it worked. Still, would rather be using DLNA.


Return to “Beginners and Newbies”

Who is online

Users browsing this forum: No registered users and 1 guest