CLOSED: Amahi Energy Saver

User avatar
jayrock
Posts: 223
Joined: Thu Dec 02, 2010 12:55 am

Re: Amahi Energy Saver

Postby jayrock » Mon Dec 12, 2011 2:41 pm

Hello Hypertense,

all I can see from the log is that indeed the service crashes and is restarted continuously. Can you please open a root console and run

Code: Select all

ruby /var/hda/web-apps/aes/html/lib/aes.rb
It should show some trace info after some 10 seconds. Please post it.

Kind regards,

jayrock

hypertense
Posts: 51
Joined: Thu Jan 27, 2011 3:53 pm

Re: Amahi Energy Saver

Postby hypertense » Mon Dec 12, 2011 2:48 pm

Here's the output.
/usr/lib/ruby/gems/1.8/gems/open4-1.1.0/lib/open4.rb:37:in `exec': Permission denied - /var/hda/web-apps/aes/html/aes-extra/installfiles/hdd-pm.sh start (Errno::EACCES)
from /usr/lib/ruby/gems/1.8/gems/open4-1.1.0/lib/open4.rb:37:in `popen4'
from /usr/lib/ruby/gems/1.8/gems/open4-1.1.0/lib/open4.rb:21:in `fork'
from /usr/lib/ruby/gems/1.8/gems/open4-1.1.0/lib/open4.rb:21:in `popen4'
from /usr/lib/ruby/gems/1.8/gems/popen4-0.1.2/lib/popen4.rb:81:in `popen4'
from /var/hda/web-apps/aes/html/lib/aes.rb:300:in `spin_down_idle_disks'
from /var/hda/web-apps/aes/html/lib/aes.rb:516
Regards

hypertense

cybernica
Posts: 21
Joined: Wed Aug 31, 2011 9:06 pm

Re: Amahi Energy Saver

Postby cybernica » Tue Dec 13, 2011 10:11 pm

Hi,

I'm also experiencing the same issue ever since I've updated to 0.9.4.

Thanks,

=======================
/usr/lib/ruby/1.8/logger.rb:517:in `initialize': Permission denied - /var/log/aes.log (Errno::EACCES)
from /usr/lib/ruby/1.8/logger.rb:517:in `open'
from /usr/lib/ruby/1.8/logger.rb:517:in `open_logfile'
from /usr/lib/ruby/1.8/logger.rb:486:in `initialize'
from /usr/lib/ruby/1.8/logger.rb:262:in `new'
from /usr/lib/ruby/1.8/logger.rb:262:in `initialize'
from /var/hda/web-apps/aes/html/lib/aes.rb:47:in `new'
from /var/hda/web-apps/aes/html/lib/aes.rb:47
=======================
Attachments
aes.log
(24.71 KiB) Downloaded 45 times

User avatar
jayrock
Posts: 223
Joined: Thu Dec 02, 2010 12:55 am

Re: Amahi Energy Saver

Postby jayrock » Tue Dec 13, 2011 11:36 pm

Hi hypertense and cybernica,

it looks like some permissions are mixed up in your installations. I don't know what going on here.

To troubleshoot, can you please run "ls -l FILENAME"

To fix the problem, try to run as root "chmod 666 FILENAME"

Replace FILENAME with "/var/hda/web-apps/aes/html/aes-extra/installfiles/hdd-pm.sh" and "/var/log/aes.log", respectively.

Kind regards,
jayrock

hypertense
Posts: 51
Joined: Thu Jan 27, 2011 3:53 pm

Re: Amahi Energy Saver

Postby hypertense » Tue Dec 13, 2011 11:53 pm

Hello jayrock

ls - l provided the following:
-rw-r--r-- 1 apache users 819 Sep 4 14:45 /var/hda/web-apps/aes/html/aes-extra/installfiles/hdd-pm.sh
After chmod it produced:
-rw-rw-rw- 1 apache users 819 Sep 4 14:45 /var/hda/web-apps/aes/html/aes-extra/installfiles/hdd-pm.sh
The Amahi Energy Saver Server still does not restart. Do I have to reinstall again?

Regards

hypertense

User avatar
jayrock
Posts: 223
Joined: Thu Dec 02, 2010 12:55 am

Re: Amahi Energy Saver

Postby jayrock » Wed Dec 14, 2011 1:09 am

Can you please start aes manually again and see what's the console output.

Something seems to be odd with permissions, but I don't fully understand what's going on. I'm traveling until the end of the week so unfortunately I cannot check the code.

/jayrock

[ Post made via Android ] Image

hypertense
Posts: 51
Joined: Thu Jan 27, 2011 3:53 pm

Re: Amahi Energy Saver

Postby hypertense » Wed Dec 14, 2011 3:03 pm

I've just tried to start the service manually and this is the error I get.
/usr/lib/ruby/gems/1.8/gems/open4-1.1.0/lib/open4.rb:37:in `exec': Permission denied - /var/hda/web-apps/aes/html/aes-extra/installfiles/hdd-pm.sh start (Errno::EACCES)
from /usr/lib/ruby/gems/1.8/gems/open4-1.1.0/lib/open4.rb:37:in `popen4'
from /usr/lib/ruby/gems/1.8/gems/open4-1.1.0/lib/open4.rb:21:in `fork'
from /usr/lib/ruby/gems/1.8/gems/open4-1.1.0/lib/open4.rb:21:in `popen4'
from /usr/lib/ruby/gems/1.8/gems/popen4-0.1.2/lib/popen4.rb:81:in `popen4'
from aes.rb:300:in `spin_down_idle_disks'
from aes.rb:516
Regards
hypertense

cybernica
Posts: 21
Joined: Wed Aug 31, 2011 9:06 pm

Re: Amahi Energy Saver

Postby cybernica » Wed Dec 14, 2011 10:37 pm

Here's when I run ruby /var/hda/web-apps/aes/html/lib/aes.rb, on my initial post i wasn't logged in as root:

Code: Select all

[root@amahivirtual ~]# ruby /var/hda/web-apps/aes/html/lib/aes.rb /usr/lib/ruby/gems/1.8/gems/open4-1.1.0/lib/open4.rb:37:in `exec': Permission denied - /var/hda/web-apps/aes/html/aes-extra/installfiles/hdd-pm.sh start (Errno::EACCES) from /usr/lib/ruby/gems/1.8/gems/open4-1.1.0/lib/open4.rb:37:in `popen4' from /usr/lib/ruby/gems/1.8/gems/open4-1.1.0/lib/open4.rb:21:in `fork' from /usr/lib/ruby/gems/1.8/gems/open4-1.1.0/lib/open4.rb:21:in `popen4' from /usr/lib/ruby/gems/1.8/gems/popen4-0.1.2/lib/popen4.rb:81:in `popen4' from /var/hda/web-apps/aes/html/lib/aes.rb:300:in `spin_down_idle_disks' from /var/hda/web-apps/aes/html/lib/aes.rb:516
Now here's after i run the additional commands requested:

Code: Select all

[root@amahivirtual ~]# ls -l /var/hda/web-apps/aes/html/aes-extra/installfiles/hdd-pm.sh -rw-r--r-- 1 apache users 819 Sep 4 07:45 /var/hda/web-apps/aes/html/aes-extra/installfiles/hdd-pm.sh [root@amahivirtual ~]# chmod 666 /var/log/aes.log [root@amahivirtual ~]# ruby /var/hda/web-apps/aes/html/lib/aes.rb /usr/lib/ruby/gems/1.8/gems/open4-1.1.0/lib/open4.rb:37:in `exec': Permission denied - /var/hda/web-apps/aes/html/aes-extra/installfiles/hdd-pm.sh start (Errno::EACCES) from /usr/lib/ruby/gems/1.8/gems/open4-1.1.0/lib/open4.rb:37:in `popen4' from /usr/lib/ruby/gems/1.8/gems/open4-1.1.0/lib/open4.rb:21:in `fork' from /usr/lib/ruby/gems/1.8/gems/open4-1.1.0/lib/open4.rb:21:in `popen4' from /usr/lib/ruby/gems/1.8/gems/popen4-0.1.2/lib/popen4.rb:81:in `popen4' from /var/hda/web-apps/aes/html/lib/aes.rb:300:in `spin_down_idle_disks' from /var/hda/web-apps/aes/html/lib/aes.rb:516
I tried to manually start AES and nothing happens. I think this is a bug with 0.9.4 since it worked fine with 0.9.3.

Thanks,

User avatar
jayrock
Posts: 223
Joined: Thu Dec 02, 2010 12:55 am

Re: Amahi Energy Saver

Postby jayrock » Thu Dec 15, 2011 12:11 am

Odd....

Pls deactivate "spin down idle disks" in the web app and see if this works.

Thnx,

jayrock

[ Post made via Android ] Image

hypertense
Posts: 51
Joined: Thu Jan 27, 2011 3:53 pm

Re: Amahi Energy Saver

Postby hypertense » Thu Dec 15, 2011 12:52 am

Hello jayrock.

I deactivated "spin down idle disks" as you suggested and now I can restart the aes server via the web app. I'll see how it works over the next day or so.

Thanks

hypertense

Who is online

Users browsing this forum: No registered users and 1 guest