Page 18 of 28

Re: Amahi Energy Saver

Posted: Thu Sep 08, 2011 10:38 pm
by kikkegek
No problem, I'm happy that it works now.

I checked the log and it still looks a little bit strange. Can you please continue to report any problems that may occur.

Brgs,

jayrock
hi jayrock...of course...I'll help in any way I can...I think you guys do great work.

I'll check the report again 2nite and report back...

Re: Amahi Energy Saver

Posted: Fri Sep 09, 2011 11:25 am
by kikkegek
I added a nzb file around 22:30 last night and closed down all clients in the network to see it the download would finish and if AES would keep the server awake. The download finished just fine. so AES probably did its magic.

see attached the log file, called aes2.log
aes2.log
(70.62 KiB) Downloaded 51 times

Re: Amahi Energy Saver

Posted: Thu Oct 20, 2011 11:59 am
by Azaron
Hello all,

first of all I must say BIG THANKS for this nice app.
I've installed it last week via one-click install, then went through the wiki and made the calendar stuff and all that...

now my Amahi gets suspended. I had some trouble with the WOL but think it works now too (since today).
The Win7-Client is beautiful :)

However, now that I have all configured and working I saw that there is a new version available since monday - directly after I installed *grmbl*
So my very simple question is:
How do i update to the new version?
Is there a way to update without loosing the config?

I ask because I only the see option to uninstall... ofc I could do so and then reinstall with one-click. Wasn't too hard - but as I had some hours spend tuning my config I would hate to stuck on a simple step afterwards and so would prefer to have a update with restored configuration.

Re: Amahi Energy Saver

Posted: Thu Oct 20, 2011 2:02 pm
by jayrock
Hi Azaron,

uninstalling and installing is currently the cleanest way of upgrading.

You will have to redo the web-app configuration and the list of monitored hosts. It shouldn't take more than a minute to set the configuration in the web app. The energy balance figures as well as the calendar stay, and there's is no change needed on the client side. All in all the effort to upgrade should be very small.

I recommend to update to the latest version as it has some nice new usability improvements. E.g with 0.9.3 it is possible to see in the web-app which of the Monitored Hosts are up and running. Since you are using the calendar function, you may find the display of the next wakeup time in the web-app useful, too.

Cheers

jayrock

Re: Amahi Energy Saver

Posted: Fri Oct 21, 2011 9:21 am
by moncapitaine
EDIT: Solved it by myself, no need to look into it.

Just forgot to delete the directories in /usr/share before installing.
Sorry to bother.

Hi jayrock,

After deleting old aes install and services aes and aes-app and installing via OneClick,
I can't get to http://aes.

log is at http://fpaste.org/cnEF/

Would appreciate if you could look into it.

aes service is running, btw.

I think the problem may be here: install elevated.log
http://fpaste.org/B5AA/

Re: Amahi Energy Saver

Posted: Fri Oct 21, 2011 10:36 am
by jayrock
Hi moncapitaine,

can you elaborate on what you had to do - normally /usr/share/aes* can stay, the installer is supposed to take care of the different cases.

Which is the version you were coming from?

Cheers,
jayrock

Re: Amahi Energy Saver

Posted: Fri Oct 21, 2011 11:30 am
by Azaron
Hi jayrock,

thanks for the answer.
I've installed the new version now and it is beautiful.
The new additions that show the wakeup times are very useful for ppl like me.

Thanks for this most useful app.

Re: Amahi Energy Saver

Posted: Sat Oct 22, 2011 9:52 am
by moncapitaine
Hi jayrock,

I deleted the install directory of version 0.82.
AES service was niot running any more, so i deleted
/etc/init.d/aes*
then tried new install.
Still could not reach http://aes
then i looked at the install-elevated.log and found the entries

Code: Select all

File /usr/share/aes/energy-logger.yml exists, skipping. File /usr/share/aes/aes-suspend.sh exists, skipping. File /usr/share/aes/aes-resume.sh exists, skipping. File /usr/share/aes-lock/example.rb exists, skipping. File /usr/share/aes-lock/example.rb exists, skipping. File /usr/share/aes-lock/example._lock exists, skipping.
So I deleted /usr/share/aes
Install worked fine, http://aes reachable.

Re: Amahi Energy Saver

Posted: Sat Oct 22, 2011 9:58 am
by jayrock
Thanks for the details.

From the log you sent it looks like AES service was constantly crashing. So it would have been nice to investigate in more detail why this happened. Maybe it was some leftovers from very old versions. But most importantly it's working now which is great!

Cheers,
jayrock

Re: Amahi Energy Saver

Posted: Sun Oct 23, 2011 1:32 am
by moncapitaine
Sadly I have to say that my report was too fast in coming.
AES client now states "Powersave is blocked. Please try again later"
The HDA won't go to sleep.
Suspending via pm-suspend works and the hda will wake via AES-Client command.

aes.log states there are locked shares: http://fpaste.org/aXWV/

How can I unlock them?