CLOSED: Amahi Energy Saver

User avatar
jayrock
Posts: 223
Joined: Thu Dec 02, 2010 12:55 am

Re: Amahi Energy Saver

Postby jayrock » Sun Oct 23, 2011 2:13 am

'smbstatus' shows which files/shares are locked. Note that if you browse a share with Explorer, it is locked as well.

moncapitaine
Posts: 39
Joined: Fri Jun 11, 2010 3:40 am
Location: East Germany

Re: Amahi Energy Saver

Postby moncapitaine » Sun Oct 23, 2011 2:32 am

Unlocked the shares, tried again, now i get:

Power Save requested: Exception.
Please check if AmahiEnergySaver is running on the server.

I checked: it is running.

log: http://fpaste.org/1znB/
Celeron G530, 8GB RAM, Intel SDD 80GB system, 8TB Storage. Fileserver and Mediaserver.

User avatar
jayrock
Posts: 223
Joined: Thu Dec 02, 2010 12:55 am

Re: Amahi Energy Saver

Postby jayrock » Sun Oct 23, 2011 4:12 am

**EDIT: I noticed a problem with installations done with the Amahi Express CD. Does this apply to you? If so, please install the latest 0.9.4 version. **

Pls execute the following command in a root terminal:

ruby /var/hda/web-apps/aes/html/lib/aes.rb

After a few minutes you will see an error message in the terminal. Please post it.

/jayrock

moncapitaine
Posts: 39
Joined: Fri Jun 11, 2010 3:40 am
Location: East Germany

Re: Amahi Energy Saver

Postby moncapitaine » Mon Oct 24, 2011 11:18 pm

Hi jayrock,

sorry for taking so long, I was out of town.

No, I do not have an ExpressCD installation.

Output of said command:

Code: Select all

/var/hda/web-apps/aes/html/lib/icalendar-parser.rb:156:in `is_upcoming_task': undefined method `-' for nil:NilClass (NoMethodError) from /var/hda/web-apps/aes/html/lib/aes.rb:157:in `is_upcoming_task' from /var/hda/web-apps/aes/html/lib/aes.rb:104:in `prevent_shutdown' from /var/hda/web-apps/aes/html/lib/aes.rb:522
Hope that helps.
Celeron G530, 8GB RAM, Intel SDD 80GB system, 8TB Storage. Fileserver and Mediaserver.

User avatar
jayrock
Posts: 223
Joined: Thu Dec 02, 2010 12:55 am

Re: Amahi Energy Saver

Postby jayrock » Tue Oct 25, 2011 12:10 am

I see. Should be fixed with 0.9.4 as well (the problem is caused by too restrictive permissions). Let me know if it works.

/jayrock

moncapitaine
Posts: 39
Joined: Fri Jun 11, 2010 3:40 am
Location: East Germany

Re: Amahi Energy Saver

Postby moncapitaine » Tue Oct 25, 2011 10:07 am

Everything working nicely now.
Thanks for taking the time.
Celeron G530, 8GB RAM, Intel SDD 80GB system, 8TB Storage. Fileserver and Mediaserver.

apiaries
Posts: 5
Joined: Wed Oct 07, 2009 2:25 pm
Location: Herefordshire UK

Re: Amahi Energy Saver

Postby apiaries » Sun Oct 30, 2011 6:40 am

I would've thought this would be an important part of any server wishing to conserve energy and yes I am interested in this subject I didn't realise it was receiving attention by yourselves I have posted a question elsewhere in the forum about energy-saving this is the one thing thats stopping me developing a server for home use I don't like the idea of something being switched on 24 7 I apologise if this appears garbled but I'm using a speech recognition program I can't spell for the life of me but that does not stop me being interested in such matters and my grammar is appalling thank you Dave

hypertense
Posts: 51
Joined: Thu Jan 27, 2011 3:53 pm

Re: Amahi Energy Saver

Postby hypertense » Mon Dec 12, 2011 3:38 am

Hello jayrock

I recently installed the latest version of Amahi Energy Saver (0.9.4) after using version 0.9.3 and have encountered a problem. The AES Server shows as stopped on the dashboard and cannot be restarted. If I reinstall it shows as started but stops every time the server is rebooted.

I have now reinstalled several times with the same result.

Any idea why?

Regards

hypertense

User avatar
jayrock
Posts: 223
Joined: Thu Dec 02, 2010 12:55 am

Re: Amahi Energy Saver

Postby jayrock » Mon Dec 12, 2011 4:22 am

Please fpaste your logs. Without logs it's impossible to troubleshoot.

/jayrock

[ Post made via Android ] Image

hypertense
Posts: 51
Joined: Thu Jan 27, 2011 3:53 pm

Re: Amahi Energy Saver

Postby hypertense » Mon Dec 12, 2011 12:17 pm

Apologies - I thought I had attached the log but I must have missed it.

It's attached now.

hypertense
aes.log
(57.76 KiB) Downloaded 84 times

Who is online

Users browsing this forum: No registered users and 2 guests