Cannot access dashboard, Phusion Passenger error

jkbuckethead
Posts: 78
Joined: Sat Jan 31, 2015 5:35 pm

Cannot access dashboard, Phusion Passenger error

Postby jkbuckethead » Sun Jun 17, 2018 2:34 pm

At the moment I cannot access my HDA web GUI. When I try to do so, after some delay I get an error message that says

"We're sorry, but something went wrong.
We've been notified about this issue and we'll take a look at it shortly."

Below this message is a link the offers "Information for the administrator of this website." When I click this it says "The Phusion Passenger application server encountered an error while starting your web application. Because you are running this web application in staging or production mode, the details of the error have been omitted from this web page for security reasons." There's more to it, but it's just boilerplate.

Normally I would just restart, and see if that fixed the problem, but I am not sure if it is safe for me to do that right now. I just installed a new hard drive to upgrade a smaller one. The smaller drive is currently in the middle of a

Code: Select all

greyhole --going
command. I don't know what it would do if I shut down right now. Would I have to repeat the going command? Is the drive removed from the config files at the beginning or end of the command?

I know that the going command is still processing because I am connected via SSH. I am monitoring the greyhole log, and it is showing constant progress.

Is there a way to restart the misbehaving dashboard app from the SSH terminal?

If not, I am inclined to wait until the -going command has run its course then restart.

User avatar
bigfoot65
Project Manager
Posts: 11300
Joined: Mon May 25, 2009 4:31 pm

Re: Cannot access dashboard, Phusion Passenger error

Postby bigfoot65 » Sun Jun 17, 2018 6:21 pm

Try:

Code: Select all

sudo systemctl restart hda-ctl
.
ßîgƒσστ65
Applications Manager

jkbuckethead
Posts: 78
Joined: Sat Jan 31, 2015 5:35 pm

Re: Cannot access dashboard, Phusion Passenger error

Postby jkbuckethead » Sun Jun 17, 2018 7:53 pm

weird, after I restarted it loaded the page that the browser was on before the error message. But, shortly after when I tried to go to another tab, apparently it crashed again and I got the error message again. There might be something else going on that's causing the crash. The drive I'm removing is just about finished so I can reboot. Hopefully that will clear it up.

User avatar
bigfoot65
Project Manager
Posts: 11300
Joined: Mon May 25, 2009 4:31 pm

Re: Cannot access dashboard, Phusion Passenger error

Postby bigfoot65 » Mon Jun 18, 2018 2:55 pm

That is odd.

Hopefully once the drive finishes all will be ok.

Please let us know.
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 2 guests