SOLVED: Samba Service won't start

zac851
Posts: 31
Joined: Tue Aug 26, 2014 7:58 pm

Re: Samba Service won't start

Postby zac851 » Sun Jan 25, 2015 4:20 am

Sorry, I could have sworn I posted an update in this thread.

I did an OS updated right after you recommended it. After everything came back up, but there were a few issues. All the services started up, but all my shares that were configured to use Greyhole, could not be accessed. The shares that were not configured to use greyhole were back working fine.. Luckily I have less than 10 total folder shares so wasn't a big deal to fix them.

To fix them, I had to delete all the shares that were configured to use Greyhole, and recreate them. After that, they were good. The next day, the same thing happened again and I had to once again, delete them and recreate them a second time. It's been 2 days now and they are good so far.

My question is, why do you think it keeps happening? I'm wishing now that I would have never installed VNC now. I've never had a reason to ever need a GUI for any of my file servers and only did it out or curiosity. Amahi had been online for nearly 100 days without a single issue which is better than any other Linux file server distro I've ever used and it seems like that one app has just causes a big mess.

When I run "systemctl status smb.service" I still get this error even though this may have nothing to do with my issue.

Code: Select all

[root@localhost ~]# systemctl status smb.service smb.service - Samba SMB Daemon Loaded: loaded (/usr/lib/systemd/system/smb.service; enabled) Active: active (running) since Sat 2015-01-24 04:38:52 CST; 24h ago Process: 820 ExecStart=/usr/sbin/smbd $SMBDOPTIONS (code=exited, status=0/SUCCESS) Main PID: 824 (smbd) CGroup: name=systemd:/system/smb.service ├─ 824 /usr/sbin/smbd ├─ 828 /usr/sbin/smbd └─28726 /usr/sbin/smbd Jan 25 04:31:10 localhost.localdomain smbd[828]: failed to retrieve printer list: NT_STATUS_UNSUCCESSFUL Jan 25 04:44:11 localhost.localdomain smbd[24383]: [2015/01/25 04:44:11.358977, 0] ../source3/printing/print_cups.c:151(cups_connect) Jan 25 04:44:11 localhost.localdomain smbd[828]: [2015/01/25 04:44:11.359218, 0] ../source3/printing/print_cups.c:528(cups_async_callback) Jan 25 04:44:11 localhost.localdomain smbd[828]: failed to retrieve printer list: NT_STATUS_UNSUCCESSFUL Jan 25 04:57:12 localhost.localdomain smbd[25902]: [2015/01/25 04:57:12.033198, 0] ../source3/printing/print_cups.c:151(cups_connect) Jan 25 04:57:12 localhost.localdomain smbd[828]: [2015/01/25 04:57:12.033928, 0] ../source3/printing/print_cups.c:528(cups_async_callback) Jan 25 04:57:12 localhost.localdomain smbd[828]: failed to retrieve printer list: NT_STATUS_UNSUCCESSFUL Jan 25 05:10:12 localhost.localdomain smbd[27715]: [2015/01/25 05:10:12.743997, 0] ../source3/printing/print_cups.c:151(cups_connect) Jan 25 05:10:12 localhost.localdomain smbd[828]: [2015/01/25 05:10:12.744281, 0] ../source3/printing/print_cups.c:528(cups_async_callback) Jan 25 05:10:12 localhost.localdomain smbd[828]: failed to retrieve printer list: NT_STATUS_UNSUCCESSFUL [root@localhost ~]#

User avatar
bigfoot65
Project Manager
Posts: 11866
Joined: Mon May 25, 2009 4:31 pm

Re: Samba Service won't start

Postby bigfoot65 » Sun Jan 25, 2015 1:57 pm

Did you reinstall Samba? Might check to see if cups is installed and remove it if you don't have a printer directly connected to the HDA.

This is an odd problem as VNC does not touch Samba. We are trying to compile some details for a bug report so this one can be traced.
ßîgƒσστ65
Applications Manager

My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 16GB RAM, 1TBx1+2TBx2+4TBx2

zac851
Posts: 31
Joined: Tue Aug 26, 2014 7:58 pm

Re: Samba Service won't start

Postby zac851 » Mon Jan 26, 2015 11:56 pm

No, I didn't reinstall samba and i get the following when removing cups

Code: Select all

No Match for argument: cups No Packages marked for removal
Also, All shares that use Greyhole broke again today. I deleted them, and recreated them and they are fine now. Any ideas as to what keeps causing them to stop working?

User avatar
bigfoot65
Project Manager
Posts: 11866
Joined: Mon May 25, 2009 4:31 pm

Re: Samba Service won't start

Postby bigfoot65 » Tue Jan 27, 2015 6:29 am

Is VNC installed correctly now? If not you might want to try installing it again. Most that had this issue didn't have any further problems after getting VNC installed.

Also, need to check the permissions on the Greyhole shares. Check /var/log/greyhole.log as well for issues.
ßîgƒσστ65
Applications Manager

My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 16GB RAM, 1TBx1+2TBx2+4TBx2

zac851
Posts: 31
Joined: Tue Aug 26, 2014 7:58 pm

Re: Samba Service won't start

Postby zac851 » Wed Jan 28, 2015 12:37 am

Yeah, VNC successfully installed on the second try but Samba was still down and somewhere on the first page of this post, you recommended an OS update which I did.

It seems like greyhole is giving this error throughout the day.

Code: Select all

Jan 28 06:43:28 INFO daemon: Greyhole (version 0.9.60) daemon started. Jan 28 06:43:28 INFO daemon: Optimizing MySQL tables... Jan 28 06:43:28 DEBUG daemon: Loading metadata store backup directories... Jan 28 06:43:28 DEBUG daemon: Found 2 directories in the settings table. Jan 28 06:43:28 DEBUG daemon: Checking symlink at /usr/lib64/samba/vfs/greyhole.so... Jan 28 06:43:28 WARN daemon: PHP Warning [2]: is_file(): open_basedir restriction in effect. File(/usr/lib64/samba/vfs/greyhole.so) is not within the allowed path(s): (/) in /usr/bin/greyhole on line 4553; BT: greyhole[L3273] r$ Jan 28 06:43:28 WARN daemon: Greyhole VFS module for Samba was missing, or the wrong version for your Samba. It will now be replaced with a symlink to /usr/lib64/greyhole/greyhole-samba40.so Jan 28 06:43:28 WARN daemon: PHP Warning [2]: is_file(): open_basedir restriction in effect. File(/usr/lib64/samba/vfs/greyhole.so) is not within the allowed path(s): (/) in /usr/bin/greyhole on line 4563; BT: greyhole[L3273] r$ Jan 28 06:43:28 WARN daemon: PHP Warning [2]: symlink(): No such file or directory in /usr/bin/greyhole on line 1493; BT: greyhole[L3273] run() => greyhole[L3245] initialize() => greyhole[L3262] samba_check_vfs() => greyhole[L4$ Jan 28 06:43:28 WARN daemon: PHP Warning [2]: is_file(): open_basedir restriction in effect. File(/usr/lib64/samba/vfs/greyhole.so) is not within the allowed path(s): (/) in /usr/bin/greyhole on line 1579; BT: greyhole[L3273] r$ Jan 28 06:43:28 INFO daemon: The Samba daemon will now restart...

zac851
Posts: 31
Joined: Tue Aug 26, 2014 7:58 pm

Re: Samba Service won't start

Postby zac851 » Wed Jan 28, 2015 1:30 am

Nevermind, thanks for your help but the problem here is user error. I was looking more into my Greyhole config and reading over the greyhole wiki and the reasons things are messed up are because I've made changes without fully understanding what I was doing or what those changes would affect.

For instance, I made errors like when I added another hard drive awhile back and mapped the share as /var/hda/files/drives/drive4/share_name instead of adding that drive to the store_pool_directory in greyhole and adding my share location as /var/hda/files/share_name. There are plenty of other things that shouldn't have been done the way I did them like file changes through the command line directly on the /var/hda/files/drives/driveX instead of mapping it as a /var/hda/files/share_name.

I've got 6 more 1.5TB hard drives to add, so the I'll probably reinstall greyhole and then add the new hard drives to the storage pool and make sure that greyhole is setup and working correctly first. I guess I should have read the greyhole wiki a little better than I did.

User avatar
bigfoot65
Project Manager
Posts: 11866
Joined: Mon May 25, 2009 4:31 pm

Re: Samba Service won't start

Postby bigfoot65 » Wed Jan 28, 2015 7:06 am

Thanks for the update. Will close this thread.
ßîgƒσστ65
Applications Manager

My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 16GB RAM, 1TBx1+2TBx2+4TBx2

Who is online

Users browsing this forum: No registered users and 1 guest