just purchased and installed zoneminder and it doesn't work

cpeddie
Posts: 29
Joined: Sat Mar 08, 2014 12:05 am

just purchased and installed zoneminder and it doesn't work

Postby cpeddie » Tue Aug 13, 2019 8:13 pm

and when I click on the link to go to it, I get the following error message:

Code: Select all

Unable to connect to ZM db.could not find driver
And I paid $10 for this? There is no relevant help in the wiki I can find. Has anyone else had this problem? Any ideas how to solve?

Thanks....

User avatar
bigfoot65
Project Manager
Posts: 11398
Joined: Mon May 25, 2009 4:31 pm

Re: just purchased and installed zoneminder and it doesn't work

Postby bigfoot65 » Wed Aug 14, 2019 6:06 am

Check /var/log/amahi-app-installer.log file for errors.

Please provide URL for the following:

Code: Select all

apaste --sysinfo
It's important that you identify the OS and Amahi version you are using when asking for help.
ßîgƒσστ65
Applications Manager

cpeddie
Posts: 29
Joined: Sat Mar 08, 2014 12:05 am

Re: just purchased and installed zoneminder and it doesn't work

Postby cpeddie » Wed Aug 14, 2019 7:28 am

It's a brand new install of Amahi 11 on Fedora. Used the install script with no changes. Here is the error log from the ZOneminder install:
======= app install begin @ 2019-08-07 21:12:52 -0700 ==========
Installing app id hknpy3eu9d under /var/hda/platform/html/script/.. ENV=production
NOTICE: redirected 'https://github.com/amahi/pooling/archive/v1.7.tar.gz' --> 'https://codeload.github.com/amahi/pooling/tar.gz/v1.7' ...
file /var/hda/tmp/amahi-download-cache/a31a0c02fa49f9b35674324dbe167d4ae0446b1b written in cache
== CreateDiskPoolPartitions: migrating =======================================
-- execute("DROP TABLE IF EXISTS disk_pool_partitions")
-> 0.0012s
-- create_table(:disk_pool_partitions)
-> 0.0132s
== CreateDiskPoolPartitions: migrated (0.0145s) ==============================

App: Greyhole UI installed
======= app install end @ 2019-08-07 21:12:56 -0700 ==========
======= app install begin @ 2019-08-12 22:49:03 -0700 ==========
Installing app id y47iytek0u under /var/hda/platform/html/script/.. ENV=production
Your HDA services have been restarted.
Your HDA services have been restarted.
App: Plex Media Server installed
======= app install end @ 2019-08-12 22:49:22 -0700 ==========
======= app uninstall begin @ 2019-08-13 12:15:07 -0700 ==========
Uninstalling app id y47iytek0u under /var/hda/platform/html/script/.. ENV=production
Your HDA services have been restarted.
App: Plex Media Server uninstalled
======= app uninstall end @ 2019-08-13 12:15:13 -0700 ==========
======= app install begin @ 2019-08-13 12:15:45 -0700 ==========
Installing app id y47iytek0u under /var/hda/platform/html/script/.. ENV=production
Your HDA services have been restarted.
Your HDA services have been restarted.
App: Plex Media Server installed
======= app install end @ 2019-08-13 12:16:07 -0700 ==========
======= app install begin @ 2019-08-13 20:01:04 -0700 ==========
Installing app id 2giemljjpb under /var/hda/platform/html/script/.. ENV=production
Your HDA services have been restarted.
Your HDA services have been restarted.
App: Greyhole LogMon installed
======= app install end @ 2019-08-13 20:01:06 -0700 ==========
======= app install begin @ 2019-08-13 20:02:09 -0700 ==========
Installing app id wu3inl696n under /var/hda/platform/html/script/.. ENV=production
NOTICE: redirected 'https://downloads.sourceforge.net/proje ... 1.1.tar.gz' --> 'https://cfhcable.dl.sourceforge.net/pro ... 1.1.tar.gz' ...
file /var/hda/tmp/amahi-download-cache/137b1dd3817fa186a2cf9103547074a3a6ab5226 written in cache
Your HDA services have been restarted.
Your HDA services have been restarted.
file /var/hda/tmp/amahi-download-cache/367ba3c5f82fe55770c70316bafcbcd2368dba24 written in cache
App: phpRecipeBook installed
======= app install end @ 2019-08-13 20:02:14 -0700 ==========
======= app install begin @ 2019-08-13 20:07:39 -0700 ==========
Installing app id yi7uxa8mlb under /var/hda/platform/html/script/.. ENV=production
Your HDA services have been restarted.
Your HDA services have been restarted.
file /var/hda/tmp/amahi-download-cache/956319338e8752e6a8f544423df61187d8b7e320 written in cache
App: ZoneMinder installed
======= app install end @ 2019-08-13 20:07:49 -0700 ==========

No errors there.

Any ideas what I should do next?

User avatar
bigfoot65
Project Manager
Posts: 11398
Joined: Mon May 25, 2009 4:31 pm

Re: just purchased and installed zoneminder and it doesn't work

Postby bigfoot65 » Wed Aug 14, 2019 10:00 am

No errors is good, but does not help with the issue.

Please send me the URL from the command I posted previously.

Also, if you have not done an OS update I would recommend it.

Do:

Code: Select all

sudo dnf update
ßîgƒσστ65
Applications Manager

cpeddie
Posts: 29
Joined: Sat Mar 08, 2014 12:05 am

Re: just purchased and installed zoneminder and it doesn't work

Postby cpeddie » Wed Aug 14, 2019 1:41 pm

When I go to the URL hda.peddie.net/zm/index.php, I see the following php errors are occuring:
Warning: array_replace(): Argument #2 is not an array in /usr/share/zoneminder/www/includes/config.php on line 52

Warning: Invalid argument supplied for foreach() in /usr/share/zoneminder/www/includes/config.php on line 63

Notice: Use of undefined constant ZM_PATH_BIN - assumed 'ZM_PATH_BIN' in /usr/share/zoneminder/www/includes/config.php on line 70

Notice: Use of undefined constant ZM_DB_HOST - assumed 'ZM_DB_HOST' in /usr/share/zoneminder/www/includes/database.php on line 32

Notice: Use of undefined constant ZM_DB_HOST - assumed 'ZM_DB_HOST' in /usr/share/zoneminder/www/includes/database.php on line 41

Notice: Use of undefined constant ZM_DB_TYPE - assumed 'ZM_DB_TYPE' in /usr/share/zoneminder/www/includes/database.php on line 54

Notice: Use of undefined constant ZM_DB_NAME - assumed 'ZM_DB_NAME' in /usr/share/zoneminder/www/includes/database.php on line 54

Notice: Use of undefined constant ZM_DB_USER - assumed 'ZM_DB_USER' in /usr/share/zoneminder/www/includes/database.php on line 54

Notice: Use of undefined constant ZM_DB_PASS - assumed 'ZM_DB_PASS' in /usr/share/zoneminder/www/includes/database.php on line 54
Unable to connect to ZM db.could not find driver
Fatal error: Uncaught Error: Call to a member function query() on null in /usr/share/zoneminder/www/includes/config.php:167 Stack trace: #0 /usr/share/zoneminder/www/includes/config.php(140): loadConfig() #1 /usr/share/zoneminder/www/index.php(46): require_once('/usr/share/zone...') #2 {main} thrown in /usr/share/zoneminder/www/includes/config.php on line 167

I performed a dnf update and here are the results from apaste:
Gathering system info ..............................Uploading (14.9KiB)...
https://paste.fedoraproject.org/paste/2 ... 8S7ihbu5Ow

Appears there is something wrong in the php config files...

User avatar
bigfoot65
Project Manager
Posts: 11398
Joined: Mon May 25, 2009 4:31 pm

Re: just purchased and installed zoneminder and it doesn't work

Postby bigfoot65 » Wed Aug 14, 2019 2:20 pm

I’m afraid the issue lies with the Express CD install method.

Are you up to reinstalling using the Minimal CD?

This is not something easily fixable otherwise.
ßîgƒσστ65
Applications Manager

cpeddie
Posts: 29
Joined: Sat Mar 08, 2014 12:05 am

Re: just purchased and installed zoneminder and it doesn't work

Postby cpeddie » Wed Aug 14, 2019 2:24 pm

Sure, up for most anything to get it working. Let me know what I need to do.

Thanks.....

User avatar
bigfoot65
Project Manager
Posts: 11398
Joined: Mon May 25, 2009 4:31 pm

Re: just purchased and installed zoneminder and it doesn't work

Postby bigfoot65 » Wed Aug 14, 2019 2:31 pm

Recommend you follow the Minimal CD instructions.

This method will work best.
ßîgƒσστ65
Applications Manager

cpeddie
Posts: 29
Joined: Sat Mar 08, 2014 12:05 am

Re: just purchased and installed zoneminder and it doesn't work

Postby cpeddie » Wed Aug 14, 2019 2:36 pm

So I need to rebuild the hda from scratch? I have 4TB of movies on my greyhole drives...won't this cause me to lose all of those?

User avatar
bigfoot65
Project Manager
Posts: 11398
Joined: Mon May 25, 2009 4:31 pm

Re: just purchased and installed zoneminder and it doesn't work

Postby bigfoot65 » Wed Aug 14, 2019 3:14 pm

Yes rebuild from scratch.

There guidance in the wiki for disconnecting Greyhole drives and reconnecting with the new install.
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 3 guests