No "Setup" button available at my http://hda dashboard

bpartin2009
Posts: 6
Joined: Mon Mar 27, 2017 2:22 pm

No "Setup" button available at my http://hda dashboard

Postby bpartin2009 » Thu Nov 29, 2018 7:58 am

I installed amahi on my fedora23 in March 2017 and it have been running pretty much unintended since. My HDA controls DCHP and I assigned the assets on my network with static IPs a while back and everything is still running. I also have DLNA running and it works fine as well.
However, I just added a Netgear ReadyNAS to the network and I want to go in and assign a static IP for that too but low and behold I there is no button or way for me to get to that screen from my http://hda dashboard. I can't get to my shares, and I can't add users. The only thing I see at the dashboard is my installed apps. Even when I click the HDA button on the dashboard the next screen shows no shares. My mobile app also lets me sign in, but when I click on my HDA, there is nothing shared. I went through the network trouble shooter and I can ping hda, http://bpartin.com, router, 8.8.8.8, and amahi.org from both the HDA and a network connected client. Network wise, everything looks great. Interal functions of the HDA seems to be running fine (DLNA, DCHP, etc) and I can SSH into the HDA remotely and do whatever. The http://hda web interface dashboard however seems to be busted and I don't know how to fix it. I need to be able to add users, create shares, and control IP leases.

Any ideas?

Thanks,
bpartin2009

User avatar
bigfoot65
Project Manager
Posts: 11104
Joined: Mon May 25, 2009 4:31 pm

Re: No "Setup" button available at my http://hda dashboard

Postby bigfoot65 » Thu Nov 29, 2018 10:42 am

Have you tried a different web browser? Cleared the cache?

Try accessing the dashboard via http://hda/tab/users/.
ßîgƒσστ65
Applications Manager

bpartin2009
Posts: 6
Joined: Mon Mar 27, 2017 2:22 pm

Re: No "Setup" button available at my http://hda dashboard

Postby bpartin2009 » Sat Dec 01, 2018 3:22 pm

Bigfoot,

I did try clearing the cache and I used Firefox, internet explorer, and Chrome on two different computers and I still get the same page.
I tried to attach two screenshots showing no setup button or advanced page available.

User avatar
bigfoot65
Project Manager
Posts: 11104
Joined: Mon May 25, 2009 4:31 pm

Re: No "Setup" button available at my http://hda dashboard

Postby bigfoot65 » Sat Dec 01, 2018 5:20 pm

Odd.

Did you try the link I provided in my previous post?

Also please provide URL for:

Code: Select all

apaste —sysinfo
ßîgƒσστ65
Applications Manager

bpartin2009
Posts: 6
Joined: Mon Mar 27, 2017 2:22 pm

Re: No "Setup" button available at my http://hda dashboard

Postby bpartin2009 » Wed Dec 05, 2018 10:23 am

So..... I'm a dumb-ass. Apparently I failed to notice that I was logging in under a non-admin user.
Once I logged in as a admin I could get to settings and set a static IP lease for my NAS
Still nothing showing up under my shares though (on the computer or in the mobile app).
I ran "systemctl status mariadb" and it shows running (I was worried that was the issue since it had a red status icon in the settings dashboard) so all seems to be good. DLNA is running and I can access and play the movies on the share drive. So any idea why no shares show up in the app?

User avatar
bigfoot65
Project Manager
Posts: 11104
Joined: Mon May 25, 2009 4:31 pm

Re: No "Setup" button available at my http://hda dashboard

Postby bigfoot65 » Wed Dec 05, 2018 7:37 pm

So..... I'm a dumb-ass. Apparently I failed to notice that I was logging in under a non-admin user.
LOL
So any idea why no shares show up in the app?
What app?
ßîgƒσστ65
Applications Manager

bpartin2009
Posts: 6
Joined: Mon Mar 27, 2017 2:22 pm

Re: No "Setup" button available at my http://hda dashboard

Postby bpartin2009 » Mon Dec 10, 2018 9:00 am

The Amahi App for iOS. I used to be able to sign in using my Amahi acct credentials and stream in videos stored on my share drive. Now I sign in and there is nothing showing on the shares to stream. Same goes for the Web browser interface at home, I can sign in as admin and look at the shares folders but it appears that there is nothing in them. However, DLNA is running and I can stream movies off of the HDA over to my TV.

User avatar
bigfoot65
Project Manager
Posts: 11104
Joined: Mon May 25, 2009 4:31 pm

Re: No "Setup" button available at my http://hda dashboard

Postby bigfoot65 » Tue Dec 11, 2018 10:09 am

As previously requested, please provide the URL for:

Code: Select all

apaste --sysinfo
I used to be able to sign in using my Amahi acct credentials and stream in videos stored on my share drive.
Is the amahi-anywhere App installed and running on your HDA
I can sign in as admin and look at the shares folders but it appears that there is nothing in them.
You cannot access shares using the HDA dashboard. Have to use a client application, such as file manager in Windows or something like pydio App.
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 2 guests