Page 1 of 1

SOLVED: Amahi, Multicraft, and Java

Posted: Tue Jun 08, 2021 8:22 pm
by gdukin
So, I am currently running a Minecraft server using Multicraft (which I currently have updated to 2.3.2-64, which is a bit behind the current 2.3.5, but updating the panel is a pain, and caused me lots of issues when I started it).

My issue today is that the new update for Minecraft (1.17) requires Java 16, as opposed to all prior versions which required Java 8. I have Java 8 installed, and everything was working fine until I updated.

I tried manually installing Java 16, but I can't seem to make it work properly. I downloaded the TAR, moved it into the file with the , updated the shortcuts, changed the version using
alternatives --config java
But..something about manually putting it in didn't seem to work, and I get the following command line error:
08.06 22:20:18 [Server] INFO Executable '/usr/bin/java' not found: No such file or directory'
08.06 22:20:18 [Multicraft] Server executable "/usr/bin/java" not found, server startup might fail!
The yum install java command just says I already have it installed.

If I use:
dnf search openjdk
it returns multiple options, but none for Java 16.

Help please?

Re: Amahi, Multicraft, and Java

Posted: Wed Jun 09, 2021 5:22 pm
by bigfoot65
Problem is that Java 16 is not native to Fedora 27.

You can try to manually install following the install latest Oracle JDK on linux tutorial.

No guarantee it will work, but probably the only solution to your problem.

Re: Amahi, Multicraft, and Java

Posted: Wed Jun 09, 2021 7:47 pm
by gdukin
Thanks...that did it. I found some different instructions, which didn't work, but those did.

Thank you very much!

Re: Amahi, Multicraft, and Java

Posted: Wed Jun 09, 2021 9:11 pm
by bigfoot65
No problem.

Marking as resolved.