AES suddenly broken (Runtime error...)

mgfernandes
Posts: 6
Joined: Sun Jan 15, 2012 5:50 am

AES suddenly broken (Runtime error...)

Postby mgfernandes » Fri Oct 19, 2012 1:17 am

Hello,

I configured Amahi-Energy-Saver working with a calendar (aes.ical) and created several events all with the same name where Amahi should be up and running. After a couple of days, working correctly the application has broken.

When accessing, app web page I get the following message: "We're sorry, but something went wrong. We've been notified about this issue and we'll take a look at it shortly."

In the aes.log file everything seems ok. I can send a copy if necessary. I have dig a little deeper in the log files and found the production.log, that seems to follow what is happening on the web page and ruby. And there I find the following error occuring when accessing the web page:

RuntimeError (Invalid recurrence rule, byday needs to be scoped by month, week or year):
/usr/lib/ruby/gems/ri_cal-0.8.8/lib/ri_cal/property_value/recurrence_rule/occurrence_incrementer/by_day-incrementer.rb:37:in `new`
...[similar error] in other functions...


Thanks in advance for any help with this issue.
Cheers,
Miguel

User avatar
bigfoot65
Project Manager
Posts: 11342
Joined: Mon May 25, 2009 4:31 pm

Re: AES suddenly broken (Runtime error...)

Postby bigfoot65 » Fri Oct 19, 2012 4:46 am

I presume this is Fedora 14.

When problems are encountered, the one way to resolve is to gradually back out some of the settings. See if that changes anything. Also did you install or change any other configurations on the HDA after installing AES?

Unfortunately I am using Ubuntu and AES is not compatible so I cannot offer much advice.
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 2 guests