Deluge server won't start

jbmia
Posts: 67
Joined: Sun Nov 07, 2010 11:59 am

Deluge server won't start

Postby jbmia » Mon Apr 23, 2012 6:54 am

Hi Guys,

Just installed Deluge and when attempting to access the web ui at http://deluge I get 'service temporarily unavailable"... so I updated my hosts file and tried again. No success. So I go back over to my control panel and notice the Deluge server is not started. When I click to start, it appears to attempt to start, but it doesn't. Server icon stays red. Watchdog is checked. I did a "tail -f /var/log/messages" while starting the server, but didn't note anything related to the start in the log that came through... Is there another log I should be checking? Can someone point me in the right direction?

Thanks!!

jbmia

PS: Realize this app is testing status, but I'm sure we all agree the app's server should at least start...

User avatar
sgtfoo
Posts: 419
Joined: Sun Jul 18, 2010 8:27 pm

Re: Deluge server won't start

Postby sgtfoo » Mon Apr 23, 2012 7:31 am

I don't use the Amahi-spawned Deluge app. Instead I use the one you just install from the web to a user login, while in the HDA local desktop, and then I initiate the Deluge webUI server.

Once the appropriate ports are forwarded, you can remotely get into Deluge from anywhere with passworded access. It's really easy, and always works for me.
SgtFoo
HDA: VM inside oVirt FX-8300 95w (2 cores for HDA), 32GB RAM (2GB for HDA)
My PC: FX-8300, 16GB RAM, 3x 1TB HDDs, Radeon HD6970 2GB video; Win10 Pro x64
Other: PC, Asus 1215n (LXLE), Debian openZFS server (3x(2x2tb) mirrors)
Modem&Network: Thomson DCM475; Asus RT-AC66U; HP 1800-24G switch

jbmia
Posts: 67
Joined: Sun Nov 07, 2010 11:59 am

Re: Deluge server won't start

Postby jbmia » Mon Apr 23, 2012 7:34 am

Thanks for the suggestion... Was going to try that, but when I go to Deluge downloads for Fedora, the oldest release they have is 15.. No downloads for 14... Am I missing something there?

JB

https://admin.fedoraproject.org/pkgdb/acls/name/deluge

User avatar
bigfoot65
Project Manager
Posts: 11339
Joined: Mon May 25, 2009 4:31 pm

Re: Deluge server won't start

Postby bigfoot65 » Mon Apr 23, 2012 8:39 am

Deluge is part of the Fedora repository. You can do a yum install to get it for Fedora 14. That's how the Amahi version works currently, so it is not the latest available. Only the latest available for Fedora 14.
ßîgƒσστ65
Applications Manager

jbmia
Posts: 67
Joined: Sun Nov 07, 2010 11:59 am

Re: Deluge server won't start

Postby jbmia » Mon Apr 23, 2012 1:23 pm

I tried the Deluge install via yum, but get the following:

Code: Select all

deluge-console-1.3.1-2.fc14.noarch: failure: deluge-console-1.3.1-2.fc14.noarch.rpm from updates: [Errno 256] No more mirrors to try. deluge-images-1.3.1-2.fc14.noarch: failure: deluge-images-1.3.1-2.fc14.noarch.rpm from updates: [Errno 256] No more mirrors to try. deluge-1.3.1-2.fc14.noarch: failure: deluge-1.3.1-2.fc14.noarch.rpm from updates: [Errno 256] No more mirrors to try. deluge-daemon-1.3.1-2.fc14.noarch: failure: deluge-daemon-1.3.1-2.fc14.noarch.rpm from updates: [Errno 256] No more mirrors to try. deluge-gtk-1.3.1-2.fc14.noarch: failure: deluge-gtk-1.3.1-2.fc14.noarch.rpm from updates: [Errno 256] No more mirrors to try. deluge-common-1.3.1-2.fc14.noarch: failure: deluge-common-1.3.1-2.fc14.noarch.rpm from updates: [Errno 256] No more mirrors to try. deluge-web-1.3.1-2.fc14.noarch: failure: deluge-web-1.3.1-2.fc14.noarch.rpm from updates: [Errno 256] No more mirrors to try.
Here's the results for a few of the actual URL's:

Code: Select all

http://mirrors.rit.edu/fedora/linux/updates/14/x86_64/deluge-web-1.3.1-2.fc14.noarch.rpm: [Errno 14] HTTP Error 404 : http://mirrors.rit.edu/fedora/linux/updates/14/x86_64/deluge-web-1.3.1-2.fc14.noarch.rpm Trying other mirror. ftp://ftp.wallawalla.edu/pub/mirrors/fedora/linux/updates/14/x86_64/deluge-web-1.3.1-2.fc14.noarch.rpm: [Errno 14] FTP Error 550 : ftp://ftp.wallawalla.edu/pub/mirrors/fedora/linux/updates/14/x86_64/deluge-web-1.3.1-2.fc14.noarch.rpm Trying other mirror. ftp://mirror.nexicom.net/pub/fedora/linux/updates/14/x86_64/deluge-web-1.3.1-2.fc14.noarch.rpm: [Errno 14] FTP Error 550 : ftp://mirror.nexicom.net/pub/fedora/linux/updates/14/x86_64/deluge-web-1.3.1-2.fc14.noarch.rpm Trying other mirror.
From above I can see that "yum install deluge" want's to pull deluge-1.3.1-2... When I check one of these mirrors, I noted what would appear a newer version available: "deluge-1.3.3-1.fc14.noarch.rpm". Anyone know how to change the install to pull this newer version instead of the old one?

Thanks!

jbmia

User avatar
bigfoot65
Project Manager
Posts: 11339
Joined: Mon May 25, 2009 4:31 pm

Re: Deluge server won't start

Postby bigfoot65 » Mon Apr 23, 2012 5:45 pm

Try

yum clean all

Then do the install again.

[ Post made via Android ] Image
ßîgƒσστ65
Applications Manager

jbmia
Posts: 67
Joined: Sun Nov 07, 2010 11:59 am

Re: Deluge server won't start

Postby jbmia » Tue Apr 24, 2012 1:55 pm

Had to fiddle a bit to get yum clean all to work.. then did a yum update... then the yum install deluge worked... Up and running. Many thanks!

But... going back to the one click install.. is that generally working for everyone? Is it just me or might that be a bug??

jbmia

User avatar
bigfoot65
Project Manager
Posts: 11339
Joined: Mon May 25, 2009 4:31 pm

Re: Deluge server won't start

Postby bigfoot65 » Tue Apr 24, 2012 2:16 pm

The one-click install of Deluge is not live. Last time I updated it, it worked but not the best client in my opinion. I think many are using qBittorrent which seems to perform better and web UI works fine.

http://www.amahi.org/apps/qbittorrent
ßîgƒσστ65
Applications Manager

jbmia
Posts: 67
Joined: Sun Nov 07, 2010 11:59 am

Re: Deluge server won't start

Postby jbmia » Thu May 03, 2012 11:21 am

Thanks. Will have a look.

edit: Took a look.. what's with the 2.7 rating?? Doesn't seem to be very well received with the rating, yet your feedback is contrary.... (?)

edit 2: Went to the app store... or whatever we call it these days... :-) and peformed the one click install of Qbittorrent... I made sure hosts was updated with my qbittorrent.xxx.com url pointing to my hda ip address , but I keep getting a 503:

Code: Select all

Service Temporarily Unavailable The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later. Apache/2.2.17 (Fedora) Server at qbittorrent."xxxx".com Port 80
I did note this in my httpd error log:

Code: Select all

[Thu May 03 14:35:42 2012] [error] avahi_entry_group_add_service_strlst("zm") failed: Invalid host name [Thu May 03 14:35:42 2012] [error] avahi_entry_group_add_service_strlst("transmission") failed: Invalid host name [Thu May 03 14:35:42 2012] [error] avahi_entry_group_add_service_strlst("qbittorrent") failed: Invalid host name [Thu May 03 14:35:42 2012] [error] avahi_entry_group_add_service_strlst("webmin") failed: Invalid host name [Thu May 03 14:35:42 2012] [error] avahi_entry_group_add_service_strlst("calendar") failed: Invalid host name [Thu May 03 14:35:42 2012] [error] avahi_entry_group_add_service_strlst("hda") failed: Invalid host name [Thu May 03 14:35:42 2012] [error] avahi_entry_group_add_service_strlst("hda") failed: Invalid host name
But zm (zoneminder), webmin, Transmission,etc come up fine... Thoughts?

:( Not having alot of luck with these one click installs lately...

User avatar
bigfoot65
Project Manager
Posts: 11339
Joined: Mon May 25, 2009 4:31 pm

Re: Deluge server won't start

Postby bigfoot65 » Thu May 03, 2012 2:01 pm

Hello,

Keep in mind BETA apps are not live, so the ratings can be misleading. Not many have access to those apps and they are not thoroughly tested.

Your problem here is the port forward I believe. You must forward port 8090 to your HDA IP address as that is the port qBittorrent operates on. I would recommend you forward both internal and external to 8090. Then go to the url and add the port to the end of it. You should see things working then.

Another step is to see if it works on the HDA while inside your network. You can also check the app install log in /var/log directory to see that it installed correctly.
ßîgƒσστ65
Applications Manager

Who is online

Users browsing this forum: No registered users and 1 guest