Can't upload images or add albums to Gallery app

lwhaney
Posts: 1
Joined: Thu Feb 11, 2010 9:15 pm

Can't upload images or add albums to Gallery app

Postby lwhaney » Thu Feb 11, 2010 9:29 pm

I'm at wits' end. I've searched this forum and gallery with no love on finding the solution. I can't seem to upload any pics or create albums through the local server, upload applet, etc. I've tried several suggestions including changing the permissions through the gallery2/lib/support. I even deleted and reinstalled the web-app several times. At one point, I made enough changes to where I didn't get any error messages and thought it uploaded, but it still didn't display any pics.

I just opened up the gallery2/html/ to 777 out of frustration thinking it was a permissions problem. This is the debug statement that I got.

Error (ERROR_COLLISION) : mkdir failed for /var/hda/web-apps/gallery2/html/g2data/albums/temp

* in modules/core/classes/GalleryAlbumItem.class at line 231 (GalleryCoreApi::error)
* in modules/core/classes/GalleryAlbumItem.class at line 154 (GalleryAlbumItem::_createDir)
* in modules/core/classes/helpers/GalleryItemHelper_advanced.class at line 234 (GalleryAlbumItem::create)
* in modules/core/classes/GalleryCoreApi.class at line 1646 (GalleryItemHelper_advanced::createAlbum)
* in modules/core/ItemAddAlbum.inc at line 80 (GalleryCoreApi::createAlbum)
* in main.php at line 250 (ItemAddAlbumController::handleRequest)
* in main.php at line 104
* in main.php at line 88

I've seen the ERROR_PLATFORM_FAILURE a few times over the past 7 days.

I could really use your help here.

Thanks in advance!

User avatar
cpg
Administrator
Posts: 2610
Joined: Wed Dec 03, 2008 7:40 am
Contact:

Re: Can't upload images or add albums to Gallery app

Postby cpg » Thu Feb 11, 2010 10:36 pm

bug filed here http://bugs.amahi.org/issues/show/437

feel free to file bugs in the future. don't fight it for 7 days!!

please login to the bug tracker and "watch" that bug to get notifications, testing it, etc.
My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 8GB RAM, 1TBx2+3TBx1

User avatar
gboudreau
Posts: 606
Joined: Sat Jan 23, 2010 1:15 pm
Location: Montréal, Canada
Contact:

Re: Can't upload images or add albums to Gallery app

Postby gboudreau » Fri Feb 12, 2010 9:22 am

See my update in the above bug.

As root, you need to create 3 directories, and you'll be good to go.
- Guillaume Boudreau

User avatar
bigfoot65
Project Manager
Posts: 11841
Joined: Mon May 25, 2009 4:31 pm

Re: Can't upload images or add albums to Gallery app

Postby bigfoot65 » Fri Feb 12, 2010 12:21 pm

This issue has been fixed. Not sure why they were not created, but added the code to the install script.

Thanks for pointing out the issue.
ßîgƒσστ65
Applications Manager

My HDA: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz on MSI board, 16GB RAM, 1TBx1+2TBx2+4TBx2

Who is online

Users browsing this forum: No registered users and 2 guests