Search found 84 matches

by bt107
Sun Oct 07, 2018 11:30 am
Forum: File Sharing
Topic: SOLVED: Problem accessing shares on new Amahi 11 install
Replies: 15
Views: 257

Re: Problem accessing shares on new Amahi 11 install

Yep. It seems to be working ok now. Thanks for your help.
by bt107
Sat Oct 06, 2018 6:57 pm
Forum: File Sharing
Topic: SOLVED: Problem accessing shares on new Amahi 11 install
Replies: 15
Views: 257

Re: Problem accessing shares on new Amahi 11 install

I think I got it. The problem was that greyhole-samba47.so doesn't get installed in /usr/lib64/greyhole for some reason. When greyhole starts and tries to initialize a samba link it fails. Samba then creates a symlink for greyhole-samba47.so but it doesn't point anywhere because the target file does...
by bt107
Sat Oct 06, 2018 12:48 pm
Forum: File Sharing
Topic: SOLVED: Problem accessing shares on new Amahi 11 install
Replies: 15
Views: 257

Re: Problem accessing shares on new Amahi 11 install

From /var/log/greyhole.log : Oct 06 15:04:15 INFO daemon: The Samba daemon will now restart... Oct 06 15:06:38 INFO daemon: Greyhole (version 0.10.15) daemon started. Oct 06 15:06:38 INFO daemon: Optimizing MySQL tables... Oct 06 15:06:39 WARN daemon: Greyhole VFS module for Samba was missing, or th...
by bt107
Sat Oct 06, 2018 12:32 pm
Forum: File Sharing
Topic: SOLVED: Problem accessing shares on new Amahi 11 install
Replies: 15
Views: 257

Re: Problem accessing shares on new Amahi 11 install

The samba-module/bin/4.7/greyhole-x86_64.so file doesn't exist on my system that I can find. Where should it be located?
by bt107
Sat Oct 06, 2018 7:03 am
Forum: File Sharing
Topic: SOLVED: Problem accessing shares on new Amahi 11 install
Replies: 15
Views: 257

Re: Problem accessing shares on new Amahi 11 install

I was reading through this page https://github.com/gboudreau/Greyhole/wiki/Inaccessible-Greyhole-Shares at the Greyhole wiki which describes my situation exactly. When I list the /usr/lib64/greyhole directory I get [root@hda greyhole]# ls -la total 260 drwxr-xr-x 2 root root 4096 Oct 5 17:20 . dr-xr...
by bt107
Fri Oct 05, 2018 2:55 pm
Forum: File Sharing
Topic: SOLVED: Problem accessing shares on new Amahi 11 install
Replies: 15
Views: 257

Re: Problem accessing shares on new Amahi 11 install

I just reinstalled 11 and checked to see if the shares were accessible before installing Greyhole and reestablishing the share pool. Although empty, each share was accessible from a Windows 10 client. Before doing anything else I installed the Greyhole GUI app and added the data drives back in follo...
by bt107
Fri Oct 05, 2018 6:12 am
Forum: File Sharing
Topic: SOLVED: Problem accessing shares on new Amahi 11 install
Replies: 15
Views: 257

Re: Problem accessing shares on new Amahi 11 install

Getting a lot of cifs errors. For example:

CIFS VFS: BAD_NETWORK_NAME: \\127.0.0.1\Pictures
CIFS VFS: cifs_mount failed w/return code = -2

This happens for each share in the pool.
by bt107
Fri Oct 05, 2018 4:52 am
Forum: File Sharing
Topic: SOLVED: Problem accessing shares on new Amahi 11 install
Replies: 15
Views: 257

Re: Problem accessing shares on new Amahi 11 install

Thanks. I've rebooted it several times thinking that might help. Yes, this is a new install. I used the upgrade path when I went to Amahi 10 and it worked flawlessly. I first tried it here with 11 but it didn't work too well so I went with a clean install.
by bt107
Thu Oct 04, 2018 6:51 pm
Forum: File Sharing
Topic: SOLVED: Problem accessing shares on new Amahi 11 install
Replies: 15
Views: 257

SOLVED: Problem accessing shares on new Amahi 11 install

I've just installed Amahi 11 and I've got a curious issue with shares and the Greyhole pool. I was previously running Amahi 10 without issues and got a wild hair to upgrade to 11. I have an HP microserver with a 1TB system drive and 3 1TB data drives in a greyhole pool. I followed the guidance to in...
by bt107
Wed Apr 11, 2018 4:25 am
Forum: Networking
Topic: Amahi and Sophos XG Firewall Home Edition
Replies: 2
Views: 231

Re: Amahi and Sophos XG Firewall Home Edition

I have a similar setup except I use Untangle instead of Sophos. I have the Untangle box connected to the modem and the Amahi box (and all other clients) connected via switch and wireless access point behind the Untangle box. You will need to have two NICs (or a dual) in your Sophos box. One for the ...